Ford Power Stroke Nation banner

1 - 12 of 12 Posts

·
Harl
Joined
·
705 Posts
Discussion Starter #1
My dad was on his way home from the farm and when he pulled out of the road that the truck was looseing power. He said he held it to the floor to make it to the nearist driveway but she never made it.. It just lost power and craped out.. Im not to sure whats the problem. I think its a fuel problem because when you crank it she acts like its only fireing on 1 cyclinder and "NO" white smoke is comeing out.. Anyone have a clue? Eaither dont help at all.. Thanks

-Cody
 

·
Registered
Joined
·
3,053 Posts
First, check the main oil level (I lost [burned] 8 quarts in 150 miles when an injector o-ring failed). If that's OK, check the fuel pressure while cranking it (at the schraeder valve on the driver's side of the fuel filter bowl). You can also try switching fuel tanks. Cheers!
 

·
Harl
Joined
·
705 Posts
Discussion Starter #4
First, check the main oil level (I lost [burned] 8 quarts in 150 miles when an injector o-ring failed). If that's OK, check the fuel pressure while cranking it (at the schraeder valve on the driver's side of the fuel filter bowl). You can also try switching fuel tanks. Cheers!
Im not getting any fuel out of it.. The fuel pump is brand new. not even 10miles on it. She wants to fire when you hold the pedal down but when your just cranking its only firein on 1 injector is seems like..
 

·
Harl
Joined
·
705 Posts
Discussion Starter #8
We goter goin.. Haha. It was out of fuel. But the funny thing is that the Tank selector on the frame is bad. Its running off the back tank but readin 1/2 tank wich is in the front tank.So no matter wich tank we have it on it pumps out the back on reads on the front.. :lame:
 

·
Kid with a Wrench
Joined
·
436 Posts
Glad you figgerd it out.

That is lame tho..

-Matt
 

·
Registered
Joined
·
1,112 Posts
Maybe we could get this thread title switched to "Another PSD owner doesn't fill up"?:ford:
 

·
Harl
Joined
·
705 Posts
Discussion Starter #11
Maybe we could get this thread title switched to "Another PSD owner doesn't fill up"?:ford:
Umm.. Idk about that one.. Its not that we didnt fill up its we didnt no that it was running on the back tank and the fuel gauge was showing what was in the front tank.. :mad:
 

·
What else?
Joined
·
4,156 Posts
Glad to hear you got it figured out! :D

Dave
 
1 - 12 of 12 Posts
Top