Ford Power Stroke Nation banner

1 - 17 of 17 Posts

·
Aussie Member
Joined
·
21 Posts
Discussion Starter #1
My F350 has around 5500 kilometers on it (3000 + miles) This afternoon the red engine light come on. Everything otherwise is normal. The handbook tells me it comes on when a service is close to being due.Engine has 91 hours on it and unless I was doing heavy towing its not soon due for service. Whats the go gentlemen?
 

·
original "REZNECK"
Joined
·
630 Posts
do you have access to a scan tool that will be the easiest way to tell what is going on
 

·
Aussie Member
Joined
·
21 Posts
Discussion Starter #3
I live 3000 mile from my dealer but I have an agent close by who could check it. Maybe I need to buy one. Any suggestions?
 

·
Super Hauler!
Joined
·
3,882 Posts
I live 3000 mile from my dealer but I have an agent close by who could check it. Maybe I need to buy one. Any suggestions?


3000 miles LOL damn thats a long ways from anywhere. Wheres the dealer? In the US!
 

·
original "REZNECK"
Joined
·
630 Posts
some parts stores will check it for you in an attempt to sell you parts. if you want to buy one i would look at some of the sponsors or maybe search scan tools i am sure someone has asked before
 

·
oilfield trucker
Joined
·
849 Posts
Unhook your battery cable for awhile, re-attach it and see if the light is still on. If that does'nt fix it then remove the bulb, find a 7.3, install bulb in 7.3, get rid of 6.4. That should fix the problem.LOLLOL:hehe:LOLLOL
 

·
Aussie Member
Joined
·
21 Posts
Discussion Starter #8
Only one place to buy a new F series in Oz is Melbourne. I'm on the other side of the country. They do have an agent here who will have the equipment. I had the aircon compressor seize last week and they are handling that so I organize them to do it. I was hoping someone might have had some first hand experiance.
I've just sold a 7.3 and it was a great engine. In comparison to the new trucks the 97 is a horse drawn cart. Shame they dont come with the old motor.
 

·
Aussie Member
Joined
·
21 Posts
Discussion Starter #14
Phoned my dealer this morning as soon as they opened. They think its a code to do with the DPF. They have had others at the same mileage. They reset it and in 95% of cases there is no further problem. I get it checked later in the week when the truck goes in for a air con compressor. I'll let you all know what it was.
 

·
Aussie Member
Joined
·
21 Posts
Discussion Starter #15
Ok,I had the codes pulled this morning. Come up as the DPF working under ideal efficiency. They have had several do it at around the same mileage. Reset it and no further problems so they say. They reflashed the puter to the latest program as well. All seems good and thanks for all the answers:ford:
 
1 - 17 of 17 Posts
Top