Ford Power Stroke Nation banner
1 - 6 of 6 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter · #1 ·
Ac issues! So my ac is not working when I had the good up most of the time it looks like the clutch is not spinning, when it does kick it it spins for maybe 1-2 seconds making a loud squealing, then kicks off then repeats over and over . I am not sure how to tell if the clutch is bad? Or compressor or what else? Any help would be appreciated
 

·
Registered
Joined
·
156 Posts
Sounds like it's low on freon or the clutch is not engaging. I'm not an A/C expert by any means but do know for about $280 i can buy a compressor , drier , and orifice tube install it and have it professionally charged for about $175 including a vacuum to make sure its not leaking. Much better than the $1500-$1700 i get quoted when calling around.
There is a mod you can do on the clutch if it's not engaging due to gap , should be able to find that here pretty easy. Otherwise buy some freon for $20 with the gauge and shoot some to it to see if it's just low enough to cause it not to engage.
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #3 ·
I actually went and got all the parts for new compressor, drier and orifiice for 218$(-10 core) plus the freon and oil, I replaced and charged myself, just borrowed the tools from autozone
 

·
Registered
Joined
·
96 Posts
I actually went and got all the parts for new compressor, drier and orifiice for 218$(-10 core) plus the freon and oil, I replaced and charged myself, just borrowed the tools from autozone
Did that fix the issue? Was your AC hit and miss...working sometimes and not others? Or not working at all and just blowing warm air?
 

·
mech 1
Joined
·
288 Posts
if you did it your self thentwo things could have happen to cause what your talking about first to much freon and the compressor relief not working.second is that the compressor is bad and is locking up reman compressors are hit and miss to say the least.
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #6 ·
the ac was never cold, what i noticed when opening the hood is the clutch would hardly ever engage and when it did it would just kick in and squeel really bad, for the sake of saving money on freon I did compressor orifice tube and the accumulator at the same time because if i replaced one and that wasnt the issue then your talking another 60$ in freon to evacuate and charge again, was going to do the clutch but that was like 98$, when a new compressor with clutch was only 144$ , after doing the install and charge everything works fine, my issue is solved
 
1 - 6 of 6 Posts
Top