Ford Power Stroke Nation banner

1 - 20 of 23 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
So the other day I was headed out of town. It was about 20 below and my pickup started acting funny. No power at all. So I thought my fuel was gelling up on me. I turned around and headed in. It died on me once but fired back up. I got it to town and put it in the garage and let it set for the day while I was out of town. Got home put some 911 in it and changed the filters. Been running ok since. But still sluggish. Well im on my way home from denver about 2 hours from home and its doing the same thing. Wont barely move itself. I noticed when I slow down from running highway speed or sit at a stop light it will start to blow white/blue smoke. Any ideas? I do have a scan gauge 2

Sent from AutoGuide.com Free App
 

·
Banned
Joined
·
328 Posts
So the other day I was headed out of town. It was about 20 below and my pickup started acting funny. No power at all. So I thought my fuel was gelling up on me. I turned around and headed in. It died on me once but fired back up. I got it to town and put it in the garage and let it set for the day while I was out of town. Got home put some 911 in it and changed the filters. Been running ok since. But still sluggish. Well im on my way home from denver about 2 hours from home and its doing the same thing. Wont barely move itself. I noticed when I slow down from running highway speed or sit at a stop light it will start to blow white/blue smoke. Any ideas? I do have a scan gauge 2

Sent from AutoGuide.com Free App
Whats your icp? Ipr?
Ficm volts?
Figured go ahead and ask

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
45 Posts
Discussion Starter #3
Icp is around 1100 cruising at 70 on level ground. Ficm is at 50 and I haven't checked my ipr. I shut it off and let it set for about 10 15 minutes and it was fine. I noticed it runs pretty good at lower speeds when im driving around town by once I get up to highway speeds it has trouble keep speed on the smallest hills. Itll hesitate and buck a little too

Sent from AutoGuide.com Free App
 

·
Banned
Joined
·
2,444 Posts
Do you still have the EGR cooler and valve?
Pull the valve out and see if it is wet...
 

·
Banned
Joined
·
2,444 Posts

·
scouts out...
Joined
·
246 Posts
Don't know where your at in wyo sounds like Cheyenne area. I would be willing to meet this weekend and take a look.
 

·
Banned
Joined
·
2,444 Posts
If your valve is wet, then your EGR cooler and oil cooler need to be replaced.
As far as the low power, I would blame the valve

Sent from AutoGuide.com Free App
 

·
Banned
Joined
·
2,444 Posts
Not so much from the valve being disabled, but more from possibly a leaking EGR cooler. I'll get a video tomorrow if how hard then engine has to work with a bad cooler cycling coolant through the engine.

Sent from AutoGuide.com Free App
 

·
Banned
Joined
·
2,444 Posts
Thats pretty high for cruising. Whats your ICP voltage at that time?
 

·
Banned
Joined
·
2,444 Posts
Watch your IPR on WOT. If it jumps up around 80 your problem is a bad IPR.
So I guess you dont want full ICP? LOL
Mine always goes to 84% (fully closed) at WOT and my HPO system is in perfect shape.

sent from my Smart Car
 

·
Registered
Joined
·
16 Posts
So I guess you dont want full ICP? LOL
Mine always goes to 84% (fully closed) at WOT and my HPO system is in perfect shape.

sent from my Smart Car
It was my understanding that the ipr shouldn't get 84%, but I could be wrong about that. I just know my particular situation was when I would give it some throttle it would always jump to 84% and fall flat on it's face. No power. Come to find out my IPR was sticking. Glad you find so much humor in my post.:evil
 
1 - 20 of 23 Posts
Top