Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
293 Posts
Discussion Starter #1
Hey guys so I was just helping my buddy with his work truck. The truck was running fine and it died. He said the tach wasnt moving, so I was thinking cps. So we get it to his house and I finally get the cps changed. Still no start. the I noticed that there was no wts light. So, going back to the days when I friend my pcm I checked the fuel bowl heater fuse. It was blown. I replaced it, blew it again. Unplugged the fuel bowl heater, and blew it again.

At this point Im stumped, what could be causing this fuse to blow? It blows as soon as I turn the key on, the wts instantly goes out. Any thoughts where to start guys?
 

·
Registered
Joined
·
293 Posts
Discussion Starter #2
Any ideas guys?
 

·
Registered
Joined
·
9 Posts
just a thought, check the wires for a short? you said with the bowl heater unplugged, it still blew? first thing I'd do is start looking for a short, but there are lots of guys on here with alot more knowledge than I've got...

could even have a short behind the fuse panel itself...

Might be time to get out that wiring diagram in the book and try to figure out where else that circuit goes that can be shorting out.
 

·
Registered
Joined
·
293 Posts
Discussion Starter #4
Well its his work truck he just told me that his boss had the flat bed come get it. Shop can fix it now. Still curious however, it was snowing is it possible the idm got wet somehow and was blowing the fuse?
 
1 - 4 of 4 Posts
Top