Ford Power Stroke Nation banner
1 - 7 of 7 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Let's start by saying thanks for the help last time and for this time. Well i have a late 99 f250 7.3 4x4, it's lifted with 35's, 4 inch full exhaust with a tuner thinks its on 60 hp gain maybe 80 can't remember. ok the problem is some weeks i'll get about 480 to 540 miles to a full tank and some weeks i'll get 150 to 228 miles to a full tank. and if i run the ac forget it can't pass a fuel station period. i've been getting fuel at the same place for months as well as a bunch of my friends.

There are times when my truck is super sluggish like has no power but if i hit a good size pot hole or a series of bumps like driving on side of the road dirt part something happens and my truck comes alive and runs like a bat out of hell. and then if i hit some more bumps it get's sluggish again.

I've already replaced cps, hpop, icp, and ipr times 2. every so often i'll run the ford diesel additive and replaced the connector to the icp. :eek:
 

·
Registered
Joined
·
853 Posts
Chip not secured in the PCM all the way?
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #7 ·
UPDATE

pulled engine harness out today found cam sensor plug wires melted together. fixed with new pig tail. installed new uvch connector on passenger side, drivers already had it. now i have a miss on number 5 cylinder.

did a buzz test and little to no buzz out of it. does anyone know what color the wire is for number 5 in the harness
 
1 - 7 of 7 Posts
Top