Ford Power Stroke Nation banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey y’all,

I’m new here but any help would be appreciated. I have a late model 1999 7.3 with 264,000 miles. I bought it from a dealership last year with 230k. It came with a 4” downpipe/straight back but was otherwise stock. The only things I really have done to it is add a TS 6 pos chip and a Napa Gold 6637 air filter. The truck ran great for 30,000 miles with reg oil changes etc. I’ve had it parked for the past 4 months but the story is, that I was driving down the interstate and it shut off. Started back up after a couple of tries and then ran another 500 miles without issue. Eventually I began to notice white smoke from the tail pipe and did the oil cap test which told me that I have a good bit of blow by...Enough to make the cap flutter slightly not just vibrate. Had it in to two different mechanics, first one replaced the IPR as the codes showed low injector pressure. It ran better afterwards and only seems to have an issue when at idle. Second mechanic did not do a full compression test but told me it would be a $13k-$14k rebuild. Basically, it always starts right up on the first try (and seems to run better after I used the hotshots Secret Stiction Eliminator to this recent oil change) but idles rough and puffs white smoke out of the exhaust until it gets warmed up. It otherwise seems smooth at higher RPMs. Thanks in advance for any pro tips.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
Sorry, just realized I was on the forum for introductions not vehicle questions!
 

·
PSN intsigator
Joined
·
6,725 Posts
Welcome to the nation from WNC.

What were the results of the halfway compression test. Are your glowplugs working?
 
1 - 3 of 3 Posts
Top