Ford Power Stroke Nation banner
1 - 20 of 23 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Truck is a 99 PSD 7.3, 4 door dually. 156,000 miles. Oil has been changed so much that after 3,000 miles you can still see through it. Truck has been well maintained. Brand new batteries as of 1 month ago.

Some history -

Truck every once in a while will jerk going down the road, like someone turned the key off real quick and turned it back on. It lasts maybe .5 seconds. Almost like you took your foot off the accelerator and jumped right back on it. It's been doing this for about 6 months or so.

In the past 3 months, the truck has been cutting off at stoplights and low speed turns, randomly. It happens with the wife quite often, but she drives the truck almost daily. I use it about 1 time every two weeks. I have driven it to work for a week straight and never had it cut off with me at a stop light or low speed turn. The truck starts right back up after this happens (according to the wife), but like I said, I have not had this happen with me in the truck. Never threw a code or check engine light

Fast forward to this evening. Happened to the wife on the way home from work, 3 times in a row (truck cutting off at a stop). Service engine soon light comes on. She gets home, I scan it, I have two codes.
P0344 (camshaft position sensor)
P0478 (Exhaust pressure control valve high input).

I have replaced the CPS with a borg warner unit about 2 months ago. This really has had no impact on this issue.

Another note-able about this is the fact that I think the heat riser in the exhaust is coming on when it shouldn't. At low engine speeds while driving, you can actually hear what sounds like the exhaust being stopped up when you get back on the accelerator lightly. When you get down on the accelerator say, 1/2 way, it goes away and the truck powers on down the road. One more thing, it has gotten pretty ####ty mileage since this has started too.

Any ideas? I'd like to know where to start looking before I go playing swap-tronics. I can buy new CPS's all day long, and new Injector pressure regulators, IDM's, etc, but I'd like to know what to look for and what to test first.

Thanks!
 

·
Registered
Joined
·
130 Posts
Whats the fuel gauge say? Anywhere near 1/4 tank I'd start looking at the sending unit.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #3 ·
I've had this happen at 1/4 tank and have had this happen with 3/4 to a full tank.
 

·
Registered
Joined
·
2,294 Posts
aftermarket cps units have a tendency to do just what the truck is doing. does it do it to your wife in about or exactly the same spots every time it does it? they get affected by radio frequency so a truck using its radio next to you could do it. or a cell phone tower or even traffic camera sensors can set them off sometimes. tons of threads on here about it. people buy one from ford and issue fixed. to fix that exhaust back pressure issue do the ebpv delete. that could be the reason for the bad fuel mileage if that is closing when warm.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
aftermarket cps units have a tendency to do just what the truck is doing. does it do it to your wife in about or exactly the same spots every time it does it? they get affected by radio frequency so a truck using its radio next to you could do it. or a cell phone tower or even traffic camera sensors can set them off sometimes. tons of threads on here about it. people buy one from ford and issue fixed. to fix that exhaust back pressure issue do the ebpv delete. that could be the reason for the bad fuel mileage if that is closing when warm.
Yea, I have sort of suspected that the exhaust backpressure valve could be coming on and causing the engine to stall at low speed. I'm definitely going to look into deleting it.
 

·
Registered
Joined
·
747 Posts
The EBPV won't cause it to stall. It'd just hiss, went through this with mine.kept coming up as cam position bank something. Stalling, idling like a cammed dragster etc. Swore it was a sticky ipr. Pulled it, cleaned it no change. Threw in a used cps and BAM problem fixed

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #7 ·
The EBPV won't cause it to stall. It'd just hiss, went through this with mine.kept coming up as cam position bank something. Stalling, idling like a cammed dragster etc. Swore it was a sticky ipr. Pulled it, cleaned it no change. Threw in a used cps and BAM problem fixed

Sent from AutoGuide.com Free App
Sounds like what mine is doing, minus the super rough idle.
Looks like a Ford or international CPS is in my future. As soon as I get one in, I'll post back with some feedback.

Anyone else have any ideas?
 

·
Registered
Joined
·
747 Posts
Crap, meant ICP SENSOR not cps. Idle would be super rough then clear up, or just shut off. Other times it'd be fine

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #9 ·
I know several on here have had similar issues. Just took the truck in this morning to the dealer to have two recalls done - the camshaft position sensor and the cruise control sensor. I'll update later on the status of the stumbling and shutoffs after we drive it for a day or two.
 

·
Registered
Joined
·
305 Posts
just out of curiousity, have you checked to see what your fuel pressure is doing?
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #11 ·
just out of curiousity, have you checked to see what your fuel pressure is doing?
Negative. Not sure where to start on that one? Is this something that is accessible from the ODB2 port, or do I need a gauge?
 

·
Registered
Joined
·
305 Posts
hook a gauge into the side of the fuel bowl.. check idle psi, then take it out for a couple of runs to see how the fuel psi is acting, if all checks good, then at least you can rule a fuel issue out.. mine holds 55-60 psi idle-wot, thats ideal for a stock setup
 

·
Registered
Joined
·
1,277 Posts
Same problem with mine. New Grey Ford cps did nothing... but it was 280 k old.

New Napa (Echlin) icp sensor......Replacing it with a Ford one next.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #14 ·
So far so good after taking it to Ford for the CPS and cruise control sensor recall. Will need to drive it for at least another tank of fuel before I say that this is the fix for my situation.
 

·
Registered
Joined
·
1,277 Posts
Just figured mine out....#116 30 amp box fuse (ignition switch). It had a blade terminal pushed into body of box fuse. Rumble strip would trigger a stall alot. Some times stopping hard at toll booths.
 

·
Registered
Joined
·
59 Posts
Try the IDM I had the same problem an I did all the sensors an had them replaced. Then I decided to swap the IDM with one I had taken out of a donor an never had the truck stall or die after .
 

·
Registered
Joined
·
747 Posts
Put a cps and ICP sensor in my dads excursion and still doing the exact same thing
 

·
Registered
Joined
·
118 Posts
We put a Borg Warner cps in my brother's truck and he had the same problems....guess some trucks are just picky about parts b/c I know others that run them with no problems at all.
 
1 - 20 of 23 Posts
Top