Ford Power Stroke Nation banner

1 - 3 of 3 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
intermittenly feels like the clutch is not engaging fully hard to shift, truck creeps forward while clutch if fully depressed. but to resolve the issue u just need to remove the clutch fluid resovoir and replace it back on then its back to normal until the next time u shut it off. then this morning i have fluid leaking from the bolted on cover on the side of the tranny "inspection cover"?. need some help guys dont knwo much about these
5/23 update... could not figure out how to update my original post.
last week the removing the cap trick failed and the only way to get the truck in gear was to start it in gear. it is as if the clutch is just barley hanging up as when you start it in gear it will slowly creep forward but stays a constant speed no matter how you rev the engine, then when u start to let the clutch out if begins to grab at the same spot as normal and you have the rest of your clutch throw.
so as most people here and the local dealer said to change the Master pre bled kit with the master and slave. so i orderded this and installed it yesterday and im left with the same result as before. any ideas where to go next? the clutch still grabs strong doest chatter just somthing i still spinning the trans when u have the clutch fully depressed im stumped. thanks in advance!
 

·
Registered
Joined
·
101 Posts
Your clutch fork could be bent. Mine has been replaced twice and acted very similar to yours but you have to pull the trany to find out
 

·
Registered
Joined
·
1,408 Posts
The pilot bearing let go and there is stuff in the splines or the input shaft is toast preventing the clutch disk from moving away from the flywheel properly.
 
1 - 3 of 3 Posts
Top