Ford Power Stroke Nation banner

1 - 20 of 33 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
my brake light came on and the truck will stop but its like its delayed from actually stopping pedal feel good just wont stop on a dime like normal. im not leaking and fluid. i noticed there was a sensor on top of the master cylinder, could that be it? or master cylinder?
 

·
PSN intsigator
Joined
·
6,734 Posts
When my 96 does that I need to adjust the rear brakes
 

·
Registered
Joined
·
5,756 Posts
Does the pedal feel harder?

It could be the vacuum pump.
 

·
PSN intsigator
Joined
·
6,734 Posts
When my vacuum pump went out the pedal got super hard and the brake light in the dash stayed on
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
Does the pedal feel harder?

It could be the vacuum pump.
it actually does i think. i dont drive it often its my "baby" lol. so going from my civic work car to it its always a big diffrence. is the vaccum pump on the passenger side up on the fire wall a black box? i kno i unhooked it to get to my valve cover bolts. but i did hook it back up.
 

·
Administrator
Joined
·
8,419 Posts
no vacuum pump is belt driven and on driver side front of engine under the ac compressor.
 

·
PSN intsigator
Joined
·
6,734 Posts
I don't think steering will be affected
 

·
Administrator
Joined
·
8,419 Posts
no on the steering. unless of course it has hydroboost instead of a vacuum pump.
 

·
Registered
Joined
·
5,756 Posts
A quick check on the vacuum pump is to start the engine and then turn on the fan through the dash vents, then push down on the brakes. If it is the pump then the air will switch from the dash vents and go to the defrost vents on top of the dash.

That is if the dash vents have air blowing out of them when it is in the vent position.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #11
A quick check on the vacuum pump is to start the engine and then turn on the fan through the dash vents, then push down on the brakes. If it is the pump then the air will switch from the dash vents and go to the defrost vents on top of the dash.

That is if the dash vents have air blowing out of them when it is in the vent position.
i tried they stayed on the vents they did not switch
 

·
Registered
Joined
·
5,756 Posts
It may not be the vacuum pump then but I still wouldn't rule it out.

But along the same lines it could be the vacuum booster

Sent from my SM-J737V using Tapatalk
 

·
Registered
Joined
·
25 Posts
Discussion Starter #13
It may not be the vacuum pump then but I still wouldn't rule it out.

But along the same lines it could be the vacuum booster

Sent from my SM-J737V using Tapatalk
ill get an update when i have time to look at it further soon. will a brake light have a code that i read from the obd2?
 

·
Registered
Joined
·
5,756 Posts
I don't believe so.

It is already telling you that there is a problem somewhere.
 

·
Registered
Joined
·
172 Posts
Have you looked at the actual brakes? I mean with the wheel off (& drum, for the rears)?

(phone app link)


Also check the wheel bearings since looseness there can cause delayed braking.

(phone app link)


No, the RABS-2 module is not connected to the OBD2 port. Read this caption & the NEXT several:

(phone app link)
 

·
Registered
Joined
·
25 Posts
Discussion Starter #16
Have you looked at the actual brakes? I mean with the wheel off (& drum, for the rears)?

(phone app link)


Also check the wheel bearings since looseness there can cause delayed braking.

(phone app link)


No, the RABS-2 module is not connected to the OBD2 port. Read this caption & the NEXT several:

(phone app link)
good info. & no i have not in a few months. had plenty of pad left when i rotated tires last. truck doesent get drove but maybe 100 miles a month. i will look again. the sensor on master cylinder could not cause any of this? i know iv had to replace just about every one of them lol, (seems these yers loved sensors lol) ill definitley check again. i guess i have alwys hd a problem with the light going on & off but never effected anything untill now. i did just put a hydra on & had to take the pcm out i could have messed something up somehow. just odd it started this 2 weeks after.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #17

·
Registered
Joined
·
172 Posts
Yeah, but you have a problem now. ;)
 
  • Like
Reactions: heavydoc

·
Registered
Joined
·
1,474 Posts
Is it the ABS light or the BRAKE light? There is a switch on the parking brake to turn the brake light on, coulda bumped it when you had the PCM out.

And I've got to agree with Doc about rear brake adjustment.

Sent from my E6810 using Tapatalk
 

·
PSN intsigator
Joined
·
6,734 Posts
I've been patiently waiting for that answer
 
1 - 20 of 33 Posts
Top