Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello all, my name Jordan and I am new to the page.

I just bought a 97 7.3 and am having a sputtering issue as listed above. I've search through the current post and couldn't find one that fit the exact criteria of my issue.

It only sputters when I'm holding the gas pedal at a steady position. And by sputter it's almost as if it's not sending diesel properly and the truck is cutting in and out but idk. It doesn't do it during idle, acceleration, or when the truck is on cruise control. It only occurs when holding the pedal steady.

Any ideas what the issues could be? Thanks in advance.
 

·
Registered
Joined
·
20 Posts
Could be a lot of things, I would first check the connections at the pedal and make sure they are secure. Have you replaced the fuel filter recently? See what kind of fuel pressure you have while steadily giving it throttle. How new is the oil and is it full? Also check the VSS on the rear of the diff.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I cleaned out the fuel bowl and changed the fuel filter. I also replaced the cam positioning sensor. The oil is full and was changed a couple months ago from what I was told, I'm about to change that tomorrow to see if it helps. And, I've never dealt with the VSS before but I'll do a little research on it and check it out.
 

·
Registered
Joined
·
5,373 Posts
If it runs normally with cruise control, the pedal is a high suspect. Does it accelerate and decelerate smoothly when you use ACCEL and COAST with the cruise?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Well I changed the oil and oil filter and there was no change.

And yes madpogue, it's smooth. is there some kind of sensor in the pedal assembly that I can change? Or do I have to replace the whole thing?
 
1 - 5 of 5 Posts
Top