Ford Power Stroke Nation banner

1 - 20 of 31 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
alright im a diesel newb, this is my first diesel and ive only had the truck for a month. ran perfect up until now.

Was slowing down coming to a stop, it cut out then came back on, then died and i coasted to a gas station. trired firing it up and u could tell it wanted to but still kept cranking. then let it sit for a min or two and it doesnt want to fire over at all and sounds like its turning real freely if u know what im saying. any help would be appresiated.

to me, it sounds like a pump but like i said im a newb to diesels but thats where i would start if it was a gasser. Isnt throwing any cel lights either.
 

·
Haters Gonna Hate
Joined
·
5,869 Posts
crank on it and see if your tach registers and if your oil pressure comes up.. make sure you have a wait to start light on in the dash.. check codes... check all your fuses with a test light or multi meter, underdash, and under hood,
 

·
Registered
Joined
·
80 Posts
Discussion Starter #5
yeah i waited for the start light for sure. im trying to get it towed home now and will check about the tach registering. i know the oil pressure just sat there though.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #6
a friend told me to change cps too. lol it seriously just broke down 20min ago and i just got a ride home. Thanks x's 100 for the quick replys guys.
 

·
Registered
Joined
·
10 Posts
cps causes alot of problems.... my trucks went out and i put a new one in it still wouldn't run after the local stealership hunted threw wiring harnesses and to other new cps plugs they found out that the new plugs make the trucks miss also so just a heads up it might need a good old style cps.... just dont want someone else getting a 2000 dollar bill for electrical tape like i did :doh:
 

·
Registered
Joined
·
80 Posts
Discussion Starter #8
when u guys talk about the cps do u mean cam pos sensor or crank pos sensor? and does anyone have a link to the fuse box diagram
 

·
Registered
Joined
·
80 Posts
Discussion Starter #9
alright....

put a new cam sensor on it, there is not one blown fuse on the whole truck, has fuel in the fuel bowl, full on oil, lol put two new batteries on it bc i drained mine and went to have them charged and actually showed up as bad.

It sounds better, really wants to run but wont. tack reads now though

so what now? im really trying to avoid a garage but so far it looks like its going that way.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #12
lol anyone in the northern KY area have a idm i could try.

Im no diesel pro by any means but i have been reading my ass off all day since this truck broke down. With the no smoke deal, im thinking idm.
 

·
you want some of this?
Joined
·
2,922 Posts
Sounds like lack of high pressure oil pressure.
Check the plug going to the IPR (injector pressure regulator)
Just behind the front cover up top. Closer to the driver side.
It has a small steel stamped nut tha holds a solenoid on here with a harness plugged into it. Check and make sure its plugged in , make sure the nut is on there. Maybe trash inside the IPR ?
ahhhttt. wait a minute here almost forgot......

Is it chipped? If so, FIRST THING____ pull the chip out, an try it. Make sure the circuit board is clean where it plugs on there. It doesnt take much to make it not run. A little dust in the wrong place on it will kill everything. Look behind the E-brake pedal, and see if theres a chip plugged into the back of the stock computer. Pretty easy to see IIRC.
Might want to unhook the batteries before pulling a chip out. I never did, but some have fried the CPU by not unhoooking them first.

Good luck!
 

·
Registered
Joined
·
80 Posts
Discussion Starter #14
its bone stock except for a 4in straight pipe.

it runs off starter fluid, could that still be something with the hpop?
 

·
All done now
Joined
·
22,486 Posts
Nope. Thats a fuel issue. Drain the fuel bowl, crank the truck and see if it fill back up. Could be a fuel pump. 97 is a mechanical pump, so you actually have to crank the truck, not just turn the key on.

Oh and BTW, starting fluid is bad on these motors. If the glow plug system is working, bad things could happen. If you really need to use ether, disable the glow plug system.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #16
yeah i know its a mech pump and when i crank it fuel does come out the fuel bowl, lol i know it wont just with the key on.

thanks for the advice on the ether
 

·
Registered
Joined
·
80 Posts
Discussion Starter #18
yes on ether it will puff white smoke, but doesnt if i just crank on it w/o either. which makes me belive the injectors arnt firing. i think i have a idm tracked down, just waiting on a call back.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #19
lmao... alright

as far as fuel pressure it has 10psi wheni crank on it and around 50 or so when running

it actually started and ran for about 20 sec then died. tried to fire back up and it wouldnt blow smoke or anything.

im now stumped and debating on going to get that idm.
 

·
I know nothing...
Joined
·
6,115 Posts
Your getting fuel but its intermitent, can you get your IDM out to inspect it. This is a good time of year for electronics to take a dump!
 
1 - 20 of 31 Posts
Top