Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey everyone, i have a 1997 7.3 with 238/100s, smith brother push rods, beehive valve springs, arp head studs that i recently just did. the truck ran perfect for 2 weeks, parked it at home over night and when i went to start it, it throws a Check engine. there’s literally no codes, i have AE scanner and it shows me live data and will do injector buzz test, just pops up with no DTC. the light randomly comes and goes, and when it’s on, it idles super rough, and smokes white. When the light goes away it runs perfectly normal. Injector buzz test came out perfect, just replaced ICP and IPR and it still randomly happens.

Thanks in advance guys.
 

·
Registered
1997 F-350 CCLB 7.Tree
Joined
·
283 Posts
Hey everyone, i have a 1997 7.3 with 238/100s, smith brother push rods, beehive valve springs, arp head studs that i recently just did. the truck ran perfect for 2 weeks, parked it at home over night and when i went to start it, it throws a Check engine. there’s literally no codes, i have AE scanner and it shows me live data and will do injector buzz test, just pops up with no DTC. the light randomly comes and goes, and when it’s on, it idles super rough, and smokes white. When the light goes away it runs perfectly normal. Injector buzz test came out perfect, just replaced ICP and IPR and it still randomly happens.

Thanks in advance guys.
odd, usally it would store the code if it is throwing a code. If possible I would see about checking the IDM if you know somone who has another just plug it in and try. I would also start to take a look at the UVCH, checked all the wires make sure there not chafed ect.

my bet is something is wrong with UVCH.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
hey, i appreciate the response! i pulled my valve covers off yesterday to unplug each injector one by one, when the code is there, the whole drivers side isn’t firing, when it goes away, every injector fires. replaced valve cover gaskets, need to do pigtails still, if that’s not it i’m going to try a new IDM
 

·
Registered
Joined
·
1,081 Posts
Could also be an open/short in the common wire from the one bank going back to the IDM.
 
  • Like
Reactions: CA7.3
1 - 4 of 4 Posts
Top