Ford Power Stroke Nation banner

1 - 7 of 7 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I looked on here for this... can't find it. The wait to start light is staying on for way to long? What causes this?

I replaced the relay... I am charging the batteries again. It is very hard to turn over.

What is the cause of the wait light staying on too long?

Thanx ahead of time!
 

·
The Original
Joined
·
7,509 Posts
I looked on here for this... can't find it. The wait to start light is staying on for way to long? What causes this?

I replaced the relay... I am charging the batteries again. It is very hard to turn over.

What is the cause of the wait light staying on too long?

Thanx ahead of time!
My truck goes off quick my dads takes forever to go off my bros truck it will vary. I don't think that is your problem.

Is it hard to crank when its hot or cold or both?
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
Yea.. turning over hard no matter what the weather. Ran fine last time I plowed snow.. about a month ago. Since then it has not turned over very well. I have had it on the charger for a long time last week... still no go. I got fresh batteries, maybe I should put them in.
I thought I read something on here about the "wait to start" light stayin on for a long period of time... that this was caused by something?
 

·
your mom
Joined
·
211 Posts
probably should put the new batterys in. also when it starts how dose it run dose it smoke alot on start up. how olds the starter.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #5
NOt sure how old the starter is. Truck has 200k on it. It does seem to smoke a bit on start up. Any pointers? I have no background info on the truck... however it does not seem the old owner was much good at keeping up the maintance... It has a very dirty K&N in it. It ran excellent the one day I plowed snow it! Unreal! But I did have to boost it one time when I shut it off.
 

·
Banned
Joined
·
924 Posts
harness for plow maybe drainin batteries down? or else maybe just some bad glow plugs?
 

·
oil burner
Joined
·
1,136 Posts
throw them new batteries in there and clean all connections,wts light should stay on up to 30 sec depending on how cold it is,at least thats what mine does.
 
1 - 7 of 7 Posts
Top