Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Here is what I have : 96 7.3 auto 2wd. I changed the fluid 2 times on this truck. It currently has mobil 1 full synthetic atf in it. My speedo would bounce a couple mph 55-60 so I changed it with a used one from ebay. Still bounces the same. Not sure if thats an issue or not. This truck will have a vibration once i get into 4th gear. It will do in with overdrive off or on. Its like a pulse, pause with no vibe, pulse, pause with no vibe. Imagine if you are counting, on every even number it pulses a shudder/vibration then every odd number its fine. This started not long after i put a php hydra tuner on the truck with it on 40 hp tow. I have tried it in stock form and it still does it. Any ideas on what I should do next?
 

·
Registered
Joined
·
1,348 Posts
The speedometer bouncing Could be a bad speed sensor in the rear differential.
It could also be something going bad in the driveline. Check your universal joints and the center support bearing .


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
So next on my list is changing the rear diff fluid. I have no clue when it was done last. Truck has 165k miles. I will check that sensor when im doing that. Also its a regular cab long bed so i dont have a cardan joint. I just crawled under the truck and if i push and pull hard on the driveshaft close to the tail on the transmission it moves a little, you can hear it too. Also there is fluid on the rubber tail piece part of the transmission. Back at the diff that is rock solid. No play.
 

·
Former Ford Trans Engr.
Joined
·
3,086 Posts
This truck will have a vibration once i get into 4th gear. It will do in with overdrive off or on.
Fourth gear *IS* overdrive. When the overdrive is turned off it cannot shift into fourth gear.

I suspect you're confusing the torque converter locking with fourth gear. Your pulse is probably an engine miss.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Okay so it must be third when I always notice it. It seems to run pretty well. Idles fine and has power too. Things I have recently done are new glow plugs, new passenger side valve cover gasket, new lift pump, 3" down pipe, and my programmer. Is this something I should get a code reader for? Ive been trying to talk myself into buying an edge cs2.
 
1 - 5 of 5 Posts
Top