Ford Power Stroke Nation banner

1 - 9 of 9 Posts

·
Cummins?$?$?$?
Joined
·
104 Posts
Discussion Starter #1
Ive got a '95 with the stock HPOP, i put a new IPRfor a '99 in it, just wondering if theres a difference, and if it would cause my ICP to drop once the oil is warm, or if its the o rings on the IPR. Mayb its the signal.

The truck hesitates to start when its cold but after about 15seconds it'll fire up it will run at normal idel for a little while but eventually you have to put t on high idel to keep it running. At first start up ICP is at 550-600 psi, but ince its warmed it gets it'll drop to 350-500psi, then when you put it on high idel it sets at 500psi? what is causing this? Any advice is appreciated.thanx
 

·
Registered
Joined
·
421 Posts
You need to put the correct IPR in your truck...OR put a 99 HPOP and resevoir on your truck .... One will not work properly withou the other. The pumps /IPR are different and NOT interchangeable without modifications . Trust me I also have a 95 ..they are Unique... after 96 it doesn't matter...
 

·
Cummins?$?$?$?
Joined
·
104 Posts
Discussion Starter #3
Sweet, have you ever experenced these problems? Hopefully changing them works,
 

·
Cummins?$?$?$?
Joined
·
104 Posts
Discussion Starter #4
ok i put the right ipr in and it didnt change any thing. Could it be the pump it self. If not what could it be?
 

·
Death Row Inmate #7
Joined
·
1,458 Posts
the only difference in the IPR's is the edge filter. i have an SD IPR in my '95 right now actually. unplug the ICP sensor and see what it does. you won't be able to read the ICP when you unplug it unless your using a mechanical guage, but if it idles normal the whole time with the ICP unplugged then thats your problem.
 

·
Cummins?$?$?$?
Joined
·
104 Posts
Discussion Starter #6
Yea im reading the ICP with a mechanical gauge so.. but anything else?
 

·
Cummins?$?$?$?
Joined
·
104 Posts
Discussion Starter #7
Another question i got is...

If the pump runs the injectors fine when its cold then that means the pump is good right? or could it still be that once the oil is warm its not able to build the pressure? ive herd both im just wonderin which is true. thanx
 

·
Registered
Joined
·
1 Posts
'94 will not start when warm

So I have a 94 and it dose not like to start when it is warmed up but starts just fine when cold it didn't start tell I was getting off the freeway and just died on me
 
1 - 9 of 9 Posts
Top