Ford Power Stroke Nation banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
having an issue with my 7.3 idi not wanting to rev over 1800-2000 and has no power , new ip and injectors from pensecola diesel ,already had to warranty one ip 4-6psi at fuel filter housing will start and run but surges some and no power , tried adjusting ip timing to no avail any help is greatly appreciated
 

·
Premium Member
Joined
·
9,187 Posts
having an issue with my 7.3 idi not wanting to rev over 1800-2000 and has no power , new ip and injectors from pensecola diesel,already had to warranty one ip 4-6psi at fuel filter housing will start and run but surges some and no power , tried adjusting ip timing to no avail any help is greatly appreciated
that rite there is a red flag for me. once upon a time they had a reputation for quality products .but the last 10 years or so, i am amazed they are still in business with all the complaints about bad products they put out
 

·
Registered
Joined
·
1,377 Posts
that rite there is a red flag for me. once upon a time they had a reputation for quality products .but the last 10 years or so, i am amazed they are still in business with all the complaints about bad products they put out


I thought the same thing , I just didn’t want to be the bearer of bad news ...


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
unfortunately i didnt do my research before getting parts from penesocola diesel im still getting a lot of white smoke and no power revs stay down is there any way to test injectors
 

·
Registered
Joined
·
635 Posts
Good news is IDI injectors are pretty inexpensive so if you do need them it aint gonna bust the budget....Sounds like the pump is retarded, do you have the timing all the way up? Do the clear hose first to make sure all the air is out from the R & R.

When I rebuilt my IDI I had issues of it starting....once it started and ran I laid on the throttle to push all the air out of the fuel system...man that was a good truck went to 600k miles before it started using oil by the gallons per week...it had 3 broken pistons but still ran.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top