Ford Power Stroke Nation banner

1 - 3 of 3 Posts

·
6.4_PowerStroke_4×4
Joined
·
44 Posts
Discussion Starter #1
I just cleaned my water separator on my 6.4 and it started and ran fine for about three to five minutes and then you can hear the motor starving for fuel and it went to cut off so I cut it off. So we tried the reset of the fuel cut off and tried to hold it down once and started and still nothing. Now when we prime the key the pumps run but you can't hear in a fuel. we tried to Schrader valve and nothing comes out when we press the valve. I've heard the story of thousand times and uh I'm not going to sit here and keep starting it and run my batteries down and burn up my pumps anybody knows the trick for the Fastway please help me out I would appreciate it. Jonah 6788986769
 

·
Registered
Joined
·
406 Posts
usually cycling the key to the on position a few times takes care of this problem
 

·
Vtwinrunning
Joined
·
14 Posts
Hi there Dave here in Minnesota. Sorry to hear your broke down. I don't know much about the 6.4 as I own a 1999-7.3 and a 2004-6.0 you say pumps? There are more than a single fuel pump on your truck? One thing I have learned about working on trucks, heavy equipment and diesels in general is you may be surprised at what you may have pumped into your tank on the last fill up. Did your troubles start after a fill up? When we have a situation like yours we always remove the incoming fuel line to the pump and push air through the line and see if you can hear the air coming through the line back into your tank, at least you can rule out a plugged fuel line. And if it was it may give you enough time to get home before it happens again. Is your fuel pump on the frame like my 99 and 2004? MY 99 pump is different than the 2004as the 2004 has the built in fuel filter. Dumb question, but have you pulled the fuel filter, inspected it or at least put in a new one.
 
1 - 3 of 3 Posts
Top