Ford Power Stroke Nation banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello everyone,
I recently purchased a 2002 F550 w/ a reman 7.3L that has approximately 150k miles on it. It has a very rough idle cold or hot it doesn't matter (no backfire, popping, or engine noise). I also noticed on tip in until about 800 RPM it shakes very bad like a dead miss but seems to go away 900 rpm and above. Tests performed below:

Fuel pressure is steady 60 psi (80 psi on initial key cycle). Fuel filter is new along with fuel tank, rail pump, and sender (tank had hole rusted through and other parts replaced as preventative). Also had blue spring kit.

Injector buzz test cylinder 7 was quieter than the others and noticed no oil out of its spout on cold startup. I replaced the injector in cylinder 7 and its working now, the dead miss at idle cold is gone but the rough idle/vibration hot or cold remains unchanged. All injectors buzz relatively close to the same. Test passes with no fault detected.

Cylinder contribution passes every time without issue (cold, hot, in gear cold etc).

Monitoring the PERDEL pids all cylinders are 0% except for cylinder 2 (right around 2% at idle, if you feather the pedal to around 750 RPM before PERDEL kicks out when its shaking very bad you can get it to 4-5% on that cylinder). Cylinder 3 and 8 also have readings but from what I've read that's pretty normal (cyl 3 is less than one and cyl 8 is around 2-2.5). Thinking it was an injector issue on cylinder 2 that injector was also replaced with no change. The cylinder 2 PERDEL still reads around 2% at idle and seems to be worse than before when feathering the pedal and then letting off it goes to 5-6% now for a few seconds before returning to 2%.

KOER running test with Forscan passes.

Under valve cover harness was replaced and circuitry to IDM was load tested with no issues.

I do not have the adapters to perform the compression test yet. I'm working on getting those right now as the last test I can think of. Has anyone else run into this and can you think of any other things to test? Any help is greatly appreciated. Thank you.
 

·
Registered
Joined
·
52 Posts
I think the perdel can only be used when warm and at idle, so I wouldn't pay attention the snap throttle readings. Mine has good perdel and good contrabution and I still get a rough/vibrating idle when warm idk what it is. Keep me informed on what you find maybe we have the same issue.
 
1 - 2 of 2 Posts
Top