Ford Power Stroke Nation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter #1
My 2000 7.3 wouldn't start yesterday tried jumping it with jumper cables on both batteries and the fuel was treated. Any idea what it is? My batteries are crap and I'm buying new ones and new connectors.
 

·
Registered
Joined
·
111 Posts
Discussion Starter #3
There is an off brand one from 5/13 and then there's one that looks like it is from 2004
 

·
Old Yeller, REBORN
Joined
·
2,284 Posts
There is an off brand one from 5/13 and then there's one that looks like it is from 2004
You can stop typing now and go get the new batteries. You will then be fine. The old one will drag down a newer one very quickly. Always replace them in pairs.
 

·
Registered
Joined
·
111 Posts
Discussion Starter #5
Bought it from Texas and those were the batteries in it. I'm in school but I will go to NAPA and buy some. What really sucks is the guy took off the factory connectors.
 

·
Registered
Joined
·
747 Posts
DO NOT use ether...USe WD40 if you have to use something
 

·
Registered
Joined
·
1,396 Posts
put the batteries in plug it in for an hour and as said earlier, lose the ether. In addition to making it fire off to hot, the ether will dry out the cylinders making it harder to turn over.
 

·
Registered
Joined
·
111 Posts
Discussion Starter #8
I'm getting batteries today and then putting them in tomorrow and taking a generator to plug it in since its sitting in a school parking lot with no outlets nearby
 
1 - 8 of 8 Posts
Top