Ford Power Stroke Nation banner

21 - 40 of 44 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #21
It’s getting significantly clearer every time. When I do the flush I’m filling with distilled, running the engine (no thermostat) for a few mins so it gets up to temp, waiting an hour to cool, then draining from the radiator petcock, lower radiator house, and block plugs. On a side note, I’ve noticed that I’m getting anywhere between 6.5-7 gallons out when I flush....which means between 1-1.5 gallons of water stays in the system that you can’t get out. I have enough distilled for 2 more flushes, so I’m gonna use all of it then at that time, based on clarity, decide if I should buy and flush more distilled or put in the ELC. Gotta head to work, hopefully I’ll finish tomorrow.
BF900772-FDAD-435C-8876-27C3733616CB.jpeg
02A6E8EE-ADA9-4A16-BF4C-E9172D57EF63.jpeg
 

·
Registered
Joined
·
15 Posts
Discussion Starter #22
So I got everything all finished and final assembled and filled with the ELC. I admit I’m a little OCD with my truck maintenance, as you can probably tell. So I have a question. When I was putting my block plugs back in for the final time, I got up in there to inspect inside the block (as best I could). It looked like inside the plug hole on the driver side
4BDFF99E-DB71-46B0-BE63-2D49BBCAE819.jpeg
there was a crack in whatever I was looking at in there. I honestly have no clue what I was even looking at inside there. I took a pic as best I could...is that something to be concerned with, or is that just normal in the casting?
 

·
Registered
Joined
·
5,959 Posts
Just looks like rust scale
 

·
Registered
Joined
·
15 Posts
Discussion Starter #24
Just looks like rust scale
Maybe. On a side note I’ll mention that the cooling system starts to rust quickly doing this process. I’m not sure if that’s because of the VC9 or what. But I did the whole process starting Late Tuesday night and I just finished a couple hours ago, a total of 8 flushes. The water I drained out this morning was not as clean as the last flush from yesterday, but after two more flushes it was basically clear before I put the ELC in. In the time it took me to drain out the last flush and install the new thermostat, degas bottle, etc there was already rust starting. These were all the flushes over Tuesday night, Wednesday, and this morning in order left to right.
E1D8EFF2-3189-451C-ABDE-297ACD1731DB.jpeg
 

·
Registered
Joined
·
15 Posts
Discussion Starter #29
Everything has been back together and running great. It ran great to begin with, this was all just preventative maintenance. From what I can see inside the radiator and down into the water pump with the thermostat removed, the system looks like it cleaned out very nicely with the VC9. In the end I ended up doing a new water pump, XDP thermostat housing, thermostat, fan clutch, all hoses, degas bottle and cap, and a few pulleys along with the tensioner and belt.
F7278D1F-A212-4435-8CFB-D86C6C7433FC.jpeg
 

·
Administrator
Joined
·
8,630 Posts
Post # 25. Seems goofy.

Sent from my E6810 using Tapatalk
ok guys. when i saw that i was on the phone and could not play detective. now that i am home on the laptop i see he shows Australia for location, but Philippines as registered location.
could be a VPN.
just keep an eye open for me, and if you see strange report it and i will take care of it.
 
  • Like
Reactions: Blue-Truck-Nut97

·
Registered
Joined
·
1,619 Posts
Everything has been back together and running great. It ran great to begin with, this was all just preventative maintenance. From what I can see inside the radiator and down into the water pump with the thermostat removed, the system looks like it cleaned out very nicely with the VC9. In the end I ended up doing a new water pump, XDP thermostat housing, thermostat, fan clutch, all hoses, degas bottle and cap, and a few pulleys along with the tensioner and belt. View attachment 202683
Nice job! You should get lots of enjoyment out of the old truck. It's nice to see you taking care of it.

What brand of degas bottle did you use?

Sent from my E6810 using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter #33
Nice job! You should get lots of enjoyment out of the old truck. It's nice to see you taking care of it.

What brand of degas bottle did you use?

Sent from my E6810 using Tapatalk
Thanks man. Everything I put on was Motorcraft, except for the XDP billet thermostat housing. The ELC was Delo.
BA654A71-FF63-4207-BCA8-C499899E2BFE.jpeg
 

·
PSN intsigator
Joined
·
7,015 Posts
ok guys. when i saw that i was on the phone and could not play detective. now that i am home on the laptop i see he shows Australia for location, but Philippines as registered location.
could be a VPN.
just keep an eye open for me, and if you see strange report it and i will take care of it.
Wait! So your saying you have a phone that can get internet to look at psn. How is that possible with the flip rotorary style phones?
 

·
Native Texan
Joined
·
9,095 Posts
ok guys. when i saw that i was on the phone and could not play detective. now that i am home on the laptop i see he shows Australia for location, but Philippines as registered location.
could be a VPN.
just keep an eye open for me, and if you see strange report it and i will take care of it.
Tom with an internet enabled phone welp time to give up on the world cause its coming to an end

Sent from my SM-G970U using Tapatalk
 

·
PSN intsigator
Joined
·
7,015 Posts
That's a beautiful truck. I'm not real big on the super duty style, but that looks good. I like the wheels!

BTW, that neighborhood looks like one I used to visit in Phoenix on occasion.

Sent from my E6810 using Tapatalk
What was her name
 
21 - 40 of 44 Posts
Top