Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
hey guys sorry if im asking something else that someone may have already asked but i looked and looked and couldnt find anything like what i went through so today i fuel up in troutdale,oregon driving home at 55 or so and my check engine light comes on all of a sudden and the truck starts slowing down i pull over light went off in the process and i push in the pedal and she revs and is running fine merge back on the freeway put my foot into it no problem then 3 mins later again same problem i floored it and nothing was happening pushed in the clutch and the truck was just idling with my foot to the floor she runs totally smooth no probs however on the second time when the light went off and all was back to normal the truck just seemed like it had some adrenaline it was just haulin ass so i replaced my cps and havent had the problem so far second thing id like to mention is sometimes when im driving and wanna get into it she seems like theres a slight delay "granted my truck is a 5 speed" but it acts as if an auto matic would when it down shifts when u get on it could this all be from my cps sensor? i wanna make sure i fixed my problem before i go to smoke on the mountain (long trip) and dont wanna break down i need all the help i can get please :bowfast:
 

·
Registered
Joined
·
104 Posts
Discussion Starter #2
ps i know these sensors are known to go out and the one i changed seemed like it had been in there for a long time had to fight it to come out and seal was squished flat and the new one went in nicely.
 

·
FORD..THE ROCK CRUSHER
Joined
·
2,347 Posts
if the light came on then it stored a code in the PCM..to be sure you fixed the problem get a scan tool and read the codes..
 

·
Registered
Joined
·
104 Posts
Discussion Starter #4
thanks drove today and didnt have anymore probs will have to have it scanned tho
 
1 - 4 of 4 Posts
Top