Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all powerstroke helpers, Ive been having a crank no start issue for a week now and I have thrown a few parts at it (cps, ipr) both motorcraft parts, I want to mention it just randomly died quickly while pulling out of my driveway, I restarted it and it fired up then shut off about 30 seconds after and never fired after that and previously I had replaced my alternator (2nd time) and it wasnt charging which led me to checking the fuse for that which had been blown. I changed it and ran fine and the next day is when she died. Im suspecting bad idm because it was running pretty shitty and couldnt pull trailers for crap. It did have little white smoke while going through 2000-2500 rpm and I have new glow plugs but almost certain the glow plugs are just fine.
 

·
Registered
Joined
·
847 Posts
Welcome to PSN! A few quick checks... is there oil in the HPOP reservoir? You can try unplugging the ICP to force the PCM to use a lookup table for the injector pressures. What year is the truck? If it is newer than 99 then you won't see the RPM gauge flicker until after the engine is running. The reality of it is that you need more information. I posted this on another thread... I'll repost it here for your benefit:
Or to save time, money and a whole lot of frustration from "throwing parts" at the thing... Get FORScan and a reliable adapter... I like my USB OBDLink EX for direct to a computer, but the BAFX Bt/Wifi or a OBDLink MX for a phone also seem to get good reviews here at PSN. I would capture and save data from the IPR, ICP, RPM, EBP, MAP, IAT, EOT and calculated torque PIDs at a minimum. Unfortunately, there is no fuel pressure PID for the 7.3.
More data will help you/us to narrow down on the problem. Your problem could be weak batteries not spinning the motor fast enough to get it going. The PCM won't allow the engine to start unless it hits a specific cranking speed. Keep us posted.

Cj
 

·
Native Californian
Joined
·
440 Posts
Google "7.3 no start flow chart". It's the most helpful. I'll try to find a link.

Sent from my Pixel 2 XL using Tapatalk
 

·
Native Californian
Joined
·
440 Posts


There ya go. Hope it helps.

Sent from my Pixel 2 XL using Tapatalk
 
1 - 4 of 4 Posts
Top