Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi guys, hoping I can find the root of my problem here. Unfortunately I'm not a big transmission guy so I'm at a loss. I have an 03 7.3 powerstroke, stock except for new injectors and an intake. About a week or so ago I noticed some shaking in my truck at about 45-50 mph, seeming to come from the center of my truck. Either thought it was a bad u joint or "out of round" rotors as I got shakes at lower speeds while on the breaks too.
Yesterday I was driving home, headed uphill on a pretty steep incline at about 60 mph, I got the shakes but smoothed out shortly after. Once I reached the plateau of the hill, well, my transmission exploded and cracked the bellhousing right from the front through the center of the trans pan, with enough force it actually shot a bolt out of the pan itself. Already looking into a new stage 2 trans, but want to know what the hell can cause this. It's a 4x4 trans but there was NO front driveshaft in at the time, and the rear I joints are newer. Could they have caused this?? Motor mounts and trans mounts seem good, fluid seemed good and like I said I'm not a big transmission guy, but the more I can learn on what caused this the better! Money is tight right now as I'm working on my associates for welding technology but don't mind expenses to assure this doesn't happen with a brand new trans. I will be welding the cracked one if possible once it's out. Will post a picture once I figure out how. Lol. Thank you in advance
 

Attachments

·
Registered
Joined
·
94 Posts
Request Please -

Is is possible to include a Link to the Topic at the new location?

I get lost trying to get there from here.

Thank you.
 
1 - 4 of 4 Posts
Top