Ford Power Stroke Nation banner
Status
Not open for further replies.
21 - 39 of 39 Posts

·
<-- Fat Bottom Girl
Joined
·
871 Posts
Discussion Starter · #22 ·
thats my guess, going to dealer 7am, they say i should have it back by the weekend or monday
 

·
1st murdered 2011 psd
Joined
·
1,387 Posts
Tune didnt raise the rpms much at all, the front of the motor is cracked, and the radiator is leaking
dang man thats terrible glad their gonna get ya up and running! going to warranty it i guess? did ya leave the mods on? i never really even paid attention to what the rpms went up to stock but i know the h&s shifts around 3k and i wind mine out to around 3400 or so in manual racing somebody...
 

·
<-- Fat Bottom Girl
Joined
·
871 Posts
Discussion Starter · #24 ·
Truck is now stock, already have the part numbers to give to the dealer, and parts are in detroit
 

·
<-•DEISEL CRAFT•
Joined
·
565 Posts
Drive it till sh sports the turbine wheel out. Lol those would be cool pics
 

·
<-- Fat Bottom Girl
Joined
·
871 Posts
Discussion Starter · #26 ·
Drive it till sh sports the turbine wheel out. Lol those would be cool pics
Was misdiagnosed, the turbo is fine. the bearing for the fan assembly failed
 

·
Registered
Joined
·
254 Posts
Correct me if I am wrong, but i am sure my 2011 has electric fans... But you said it cracked your block? Just curious how... Do you have pictures, just so we can see what the heck happened. This seems so strange. But the new Explorer fans were failing too! They were all built in France and all of the early fans on the explorers had bad bearings.
 

·
<-- Fat Bottom Girl
Joined
·
871 Posts
Discussion Starter · #28 ·
took a better look today, the fan is mounted to a bracket. the bracket it broken, and the bearing failed. the fan has a electric clutch to engage it. i towed the truck to the dealer this morning, the parts are in detroit and i should have my truck back by saturday or monday
 

·
<-- Fat Bottom Girl
Joined
·
871 Posts
Discussion Starter · #29 ·
got a update from the dealer i mgiht have my truck back tonight or tomorrow morning
 

·
<-- Fat Bottom Girl
Joined
·
871 Posts
Discussion Starter · #30 ·
picked my truck up last night at 630pm, mods reinstalled last night and the coal is rolling again lol
 

·
1st murdered 2011 psd
Joined
·
1,387 Posts
LOL schwing!! they got u up and running quick!!
 

·
Registered
Joined
·
121 Posts
And the stealer don't know you had tune in it ? Or they don't care ?
Anyhow,I'm glad the turbo is ok and you're all fixed up.
 

·
<-- Fat Bottom Girl
Joined
·
871 Posts
Discussion Starter · #33 ·
Truck was put to stock and I told them I didnt want any new reflash done on my truck. So they never plugged the computer into my truck
 

·
Registered
Joined
·
121 Posts
Truck was put to stock and I told them I didnt want any new reflash done on my truck. So they never plugged the computer into my truck
That's awesome,but they didn't say anything about DPF and EGR delete?? Or did you put that back as well!
 

·
<-- Fat Bottom Girl
Joined
·
871 Posts
Discussion Starter · #35 ·
Everything was put back lol
 

·
Registered
Joined
·
3 Posts
Stopped for a coffee tonight left my truck running and noticed it had a knock. Sounds like it is coming from the area in which the turbo is. Still builds boost, no oil coming out exhaust, not smoking. Nursed it home and noticed sound progresses with rpm and now has a squeaky sound added to it. when I shut it off the sound continuess to come from the turbo area as the turbo spools down. Truck has 6200 miles on it, spartan warhammer added , dpf delete, and egr delete done at 4000 miles. No check engine lights or codes thrown. Going to take to dealer on monday, my guess is the turbo is on its way out
 

·
Registered
Joined
·
3 Posts
Stopped for a coffee tonight left my truck running and noticed it had a knock. Sounds like it is coming from the area in which the turbo is. Still builds boost, no oil coming out exhaust, not smoking. Nursed it home and noticed sound progresses with rpm and now has a squeaky sound added to it. when I shut it off the sound continuess to come from the turbo area as the turbo spools down. Truck has 6200 miles on it, spartan warhammer added , dpf delete, and egr delete done at 4000 miles. No check engine lights or codes thrown. Going to take to dealer on monday, my guess is the turbo is on its way out
What was done to get it fixed
 

·
Super Moderator
Joined
·
5,537 Posts
This thread is 11 years old and the poster is not active. Please start a new thread.
 
21 - 39 of 39 Posts
Status
Not open for further replies.
Top