Ford Power Stroke Nation banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
So my 6.4 seems like it has completely lost its power. Keep in mind it is stock no tune exhaust or anything. From a dead stop it accelerates fine up until about 45 mph and some times it shifts hard out of what I'm think is 3 or 4th gear and sometimes it will rev up to about 2500 rpm and the speed and rpm just stalls. I have to let of the gas and ease back on it for it to go faster. The other day I was getting on the highway and the pedal to the floor and my speed was just slowly rising. I've had some people tell me the torque converter, clutch is slipping, or the exhaust filter is backed up. Can anybody help me out?
 

·
Registered
Joined
·
1,945 Posts
How many miles on it? Is it building boost?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
235 Posts
Are you tuned? Are you seeming any codes.. If you are all stock, maybe a good idea to get a code reader on it, if you are close to Harrisburg, Pa. I can help. With info provide we can only guess. ????
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Are you tuned? Are you seeming any codes.. If you are all stock, maybe a good idea to get a code reader on it, if you are close to Harrisburg, Pa. I can help. With info provide we can only guess. ????
no tune and no check engine light or anything. im starting to wonder if the guy that had it before me had a tune on it because I'm starting to think it has something to do with the computer because the truck runs better before the transmission warms up than it does after it's warm.
 

·
Registered
Joined
·
1,945 Posts
If you can find a tuner or scanner that lets you navigate a little bit, I would clear your KAM. That will reset the trans computer.. also at 170k I would definitely be dropping the dpf at least for a cleaning with a pressure washer and inspection.. if it's not breathing, it's not running well...

Also, I believe when you hit 45mph on the 6.4 that's the switch over from the low pressure turbo to the high pressure turbo. Hopefully some one can verify this?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
It's just weird because sometimes it runs pretty good and then I can go in a store or something and when I get back in it I almost have to drive it like a manual by letting off the gas and easing back on so the transmission will change gears.
 
1 - 7 of 7 Posts
Top