Ford Power Stroke Nation banner

1 - 12 of 12 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
I have a 08 6.4, mini max,afe intake,4" turbo back exh.80,000 miles.never had any issues,untill today.....I saw a small puddle under the truck today,and discovered what appears to b a very small coolant drip.if u look up at it it is just to the left of where the lower hose connects to the water pump.there is a small drip not coming from the hose or the pump its coming from the other sideof the hose(not the pump side)I am not sure what's up in that area.anybody got any ideas?
 

·
Registered
Joined
·
57 Posts
Discussion Starter #2
O and as crazy as this sounds the truck is running 6-10 degrees cooler all the sudden
 

·
7.3 Enthusiast
Joined
·
682 Posts
Your upper radiator hose oring is probably leaking. Buy the revised Ford one if possible. Seems fairly common.
 

·
Registered
Joined
·
544 Posts
Your upper radiator hose oring is probably leaking. Buy the revised Ford one if possible. Seems fairly common.
I had this as well...Some other t fitting at the same time...warranty will cover it
 

·
Registered
Joined
·
40 Posts
I have a 08 6.4, mini max,afe intake,4" turbo back exh.80,000 miles.never had any issues,untill today.....I saw a small puddle under the truck today,and discovered what appears to b a very small coolant drip.if u look up at it it is just to the left of where the lower hose connects to the water pump.there is a small drip not coming from the hose or the pump its coming from the other sideof the hose(not the pump side)I am not sure what's up in that area.anybody got any ideas?
This is a late response but just went through this with my 08. Long story short, check your upper radiator hose where it goes into the upper thermostat...there is a common leak that starts there and trickles down which makes you think its coming from somewhere more expensive to fix. I picked up two replacement gaskets, 1 clip, and a gallon jug of coolant...took 15 mins to complete. There is an updated upper hose that has a WHITE plastic end piece that attaches to the theromstat housing (this one has 2 gaskets) vs the all black hose (which I have). No issues since....
 

·
Professional American, guarding our constitution.
Joined
·
9,453 Posts
New member, first post.. This caught my eye and had to offer my $.02...

My 08 had a similar issue with the mystery puddle of coolant.. After reaching operating temp/pressure, I'd get a steady drip drip drip off of the front bumper / plow frame. I took it to Ford (school buddy is a diesel tech there) and was told that this is a common issue with the 08-09 radiators. Apparently whoever they buy them from doesnt crimp the side tanks on adequately and upon reaching op pressure, coolant can seep past. Ford issued a voluntary recall on this back in 08, but due to the flood (haha pun) of returns / cost of replacing, they retracted it. It *is* a waranty issue and will be rectified if you still have coverage, just unfortunate that after shelling out a considerable expense for a product, it is our responsibility to bring repairs to their attention.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #10
I appreciate your input,however,mine only does it when its cold.when at operating temp,it will not drip.it only does it overnight.so I have made the assumption through feedback that its a o ring.just has not done it enough for me to "put it back to stock"to get it fixed.haha
 

·
Beef
Joined
·
1,565 Posts
I didn't not put my back to stock. I called the shop, tracked down a tech who was in the know for the 6.4. He told me leave it, bring it in. I tuned it to stock for the pcm update but left the rest alone.
I got a new belt tensioner and a new updated coolant system due to warranty/TSB coverage @ 70k miles.
 

·
I still play with trucks
Joined
·
183 Posts
What did they do to your coolant system?

updated tensioner?
 
1 - 12 of 12 Posts
Top