Ford Power Stroke Nation banner

1 - 9 of 9 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter #1
im trying to help my buddy get his truck running its an 05 6.0 auto. for the last couple days its had a weird hiccup when at idle even when stopped at a light. its been getting harder to start and yesterday he went to leave and his truck wouldnt start. he hears the fuel pump working then goes to start it and all it does is spin and never fires. he knows he needs a new fuel filter but could this be the cause. we would appreciate any help thanks in advance
 

·
I Just Break Stuff
Joined
·
2,201 Posts
Is it building oil presure while it's spinning over?
 

·
Registered
Joined
·
93 Posts
Discussion Starter #4
im pretty much trying to come up with a list of ideas cause im goin over to try to help him in the morning
 

·
I Just Break Stuff
Joined
·
2,201 Posts
Yea, watch the gauge to see if it's building presure while cranking. That would be my first starting point. A good scan tool would come in handy if you have one. Does it crank and run when it's cold?
 

·
Registered
Joined
·
93 Posts
Discussion Starter #6
i think it was cold not sure tho and we have his sct to check codes is that good enough
 

·
Registered
Joined
·
81 Posts
quick oil check unspin the oil filter put a screw driver to hold down the oil return flap have a buddy crank it a little if oil fills up your lpop is ok now check your high pressure oil pump the icp sensor is on the passenger side front valve cover unscrew this sensor adapt a oil pressure gauge o to at least 1000 see if it builds up at least 500 psi when cranking if not it might be stc fitting failure or d ring failure or stand pipe orings
 

·
I Just Break Stuff
Joined
·
2,201 Posts
Glad to hear y'all figured it out
 
1 - 9 of 9 Posts
Top