Ford Power Stroke Nation banner

21 - 40 of 63 Posts

·
Registered
Joined
·
186 Posts
Discussion Starter #21
Well should hear back from the dealer today.................
 

·
Banned
Joined
·
1,378 Posts
Check ebp sensor mine frayed and caused the vanes not to function also check vgt soleinoid and wires going to it sounds like stuck vanes, does it whistle as normal at idle?
 

·
Registered
Joined
·
186 Posts
Discussion Starter #23
No word yet, ebp was just changed but after the egr cooler went it could be balled again. I can't really say if it whistles at idle.......I dont think so
 

·
Registered
Joined
·
249 Posts
Check ebp sensor mine frayed and caused the vanes not to function also check vgt soleinoid and wires going to it sounds like stuck vanes, does it whistle as normal at idle?
How would I check ebp sensor?
 

·
Registered
Joined
·
186 Posts
Discussion Starter #27
the ebp is on the drivers side of the motor, its actually easy to get at, they plug up with soot along with the little tube
 

·
Registered
Joined
·
186 Posts
Discussion Starter #28
Well guys the dealer just called and said all my issues are from a bad altenator???? Not puttin out enough volts to run the FICM among other things........not sure I really buy that. Any input on that???
 

·
Banned
Joined
·
1,794 Posts
I believe it to be very possible. i had a f150 before my 6.0. alt went out on it and it killed it. i imagine the same possible for a diesel.
 

·
Registered
Joined
·
186 Posts
Discussion Starter #30
Just did some reading and it seems its very possible, messes with the FICM, ICP, and every other computer on board, I guess I wiull find out tomorrow when I pick it up
 

·
Registered
Joined
·
186 Posts
Discussion Starter #32
Just got my truck back new alt did not fix the problem.. No boost till 2500 rpm lots of black smoke. If it ever stops raining here gonna look for cracked pipes I guess
 

·
CH-46 never forgoten
Joined
·
117 Posts
like stated sounds like your running with a smoke switch on i would check wires and all to the turbo ur vanes are fing up the no boost till 2500 tells that
 

·
Registered
Joined
·
186 Posts
Discussion Starter #34
Hey guys Ford ut a new turbo in my truck, still has the same issue...........could it have something to do with the waste gate????
 

·
Registered
Joined
·
186 Posts
Discussion Starter #35
Do 6.0 even have a waste gate????
 

·
Registered
Joined
·
85 Posts
i am pretty sure they dont have a waste gate. i would check your wires going to the turbo cause mine were messed up and did the same thing it didnt whistle idling and took forever to get up to speed then would blow tons of smoke and still blow smoke while driving
 

·
Hood Rich
Joined
·
2,873 Posts
no waste gate, its a VGT, it has vanes that control exhaust pitch.... I have seen brand new turbos put on and fail, simply due to the fact they re-use the solenoid that actuates the vanes.... I just had to warranty one out
 

·
Registered
Joined
·
1,250 Posts
No wastegate, if it was the egr stuck open I don't see it building good boost on the top end. Also I wouldn't think a ficm issue because fueling doesn't seem to be an issue. Not sure What sensors are used in controlling the turbo but boost and ebp are the only I no of so check the ebp like stated and if that isn't it would almost have to be chaffed or corroded wires going to the vgt solenoid or the solenoid itself which I think is part of the turbo. I am by no means a 6.0 tech but your problem I would say is deffinetly vgt related
 

·
Hood Rich
Joined
·
2,873 Posts
being Ford doing the work, I would imagine they checked EBP sensor and tube, along with EGR operation, MAP sensor, etc... If they just threw a turbo on and didnt fixed it, Id be pissed
 
21 - 40 of 63 Posts
Top