Ford Power Stroke Nation banner

1 - 20 of 21 Posts

·
Registered
Joined
·
233 Posts
Discussion Starter · #1 ·
Anyone know how to take a 6.0 injector apart or know a thread that can show me i have searched but cant find anything. Thanks guys
 

·
Registered
Joined
·
233 Posts
Discussion Starter · #3 ·
well i know how it all works my dad has gotten into some bad fuel im just thinking about taking them apart to clean them we got the fuel system cleaned out up to the injectors but it still wont fire. Im a ASE mechanic so i know a little about what goes on with them im just looking for a parts break down of them it wont run now so what can i loose ya know
 

·
Registered
Joined
·
1,473 Posts
There shouldn't be any reason to take the injectors apart. Debris didn't get past both filters. Have you verified adequate fuel pressure and HPOP pressure?
 

·
Registered
Joined
·
475 Posts
I wouldn't take them apart either. I took one of my old stockers apart and there is a lot of small pieces with close tollerances that have the potential to get damaged. So I would check some other things to see if that is your problem or else go buy another set of good ones before you decide to pull them apart.
 

·
Registered
Joined
·
233 Posts
Discussion Starter · #7 ·
well the amount of trash and water i pulled from the system im sure something got to them and yes the HPOP and fuel pressures are good. im not to worried about it a can try to take them down and if they never work again what have i lost? IF THEY ARE BAD.
 

·
The Unseen Mod
Joined
·
4,123 Posts
Like said above, Ive taken them apart thanks to Full Force Diesel guiding me to do it. But honestly if you take that chance and put things in the wrong way your gonna have problems which could lead to other issues.
 

·
Damnkids Motorsports
Joined
·
2,260 Posts
How is debris getting past both filters and to your injectors? I'd figure that issue out before fixing anything injector related, otherwise it's just going to happen again.
 

·
Harry Callahan
Joined
·
991 Posts
It's not debris killing them, it's water. The plunger scores easy when it has no lubrication, water will wipe out these injectors asap, so if water is the prob they are toast. Cass makes injector work look easy so he is a good role model, but he is very busy with his work and his singing quartet practice.
 

·
The Unseen Mod
Joined
·
4,123 Posts
I got him on speed dial LOL. Suppose to call him tomorrow as I tear into mine again. What fun.
 

·
Registered
Joined
·
233 Posts
Discussion Starter · #12 ·
That what i think more than anything is water being the problem. How do i get up with this guy. i pumped out 18 gal. of fuel let it sit for a day dumped it and saw atleast 6-7 gal of water in the last 2 cans of fuel
 

·
Harry Callahan
Joined
·
991 Posts
Look up Full Force Diesel. There is no better injector guru than Cass.
 

·
"resident smarty pants"
Joined
·
4,678 Posts
That what i think more than anything is water being the problem. How do i get up with this guy. i pumped out 18 gal. of fuel let it sit for a day dumped it and saw atleast 6-7 gal of water in the last 2 cans of fuel
The WIF light never came on? The HFCM only holds 0.2 pints (100 cc) of water .............. then it pressures up and restricts flow (and damages injectors) or lets water through (and damages injectors).

Most aftermarket fuel filters will bypass more quickly than the proper ones - Motorcraft, Racor, International.
 

·
Registered
Joined
·
1,473 Posts
I've never seen my WIF light come on, and I've gone 6+ months without draining it before.
 

·
"resident smarty pants"
Joined
·
4,678 Posts
I haven't ever seen the WIF light either - Clearly I have not gotten any fuel w/ water in it (in this truck). It does happen though and it just doesn't take much to fill the water reservoir in the HFCM. Once you do, it will begin building the pressure that causes bypassing.

Actually this is why Ford came out w/ the modified fuel filter - it will withstand more pressure drop than the original design.
 

·
Registered
Joined
·
233 Posts
Discussion Starter · #19 ·
I open up the HFCM and the little copper contacts were croded?? beyond anything i ever seen i guess from the water. but i sent it to my local ford place and had them run a scan tool on it it WAS'NT reading any HP oil on their scanner. I guess mine is a damn lie. but tore into it today found the screen busted going to the HPOP and a broke screen on the IPR. Im getting a IPR in the morning i hope maybe it just got stuck in the closed position IDK wishful thinking. Any other ideas??? I hope it didnt fry the HPOP with the trash that got sucked up in the pump. I dont know to much about these 6.0 motors just what i have tought my self and you guys input. Any one know if that IPR valve getting stuck and not letting it run or build HP oil?
 
1 - 20 of 21 Posts
Top