Ford Power Stroke Nation banner

1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I am a 7.3 man but I purchased a 04 6.0 the other day and cel came on during drive home i have tried all the simple stuff that ive bine told and no change. The problem is it will not open up on full throttle it will go to 2500-3000 and just stops and it has no turbo whissle through straight pipe, but if you unplug the ebp sensor it runs very strong and loud turbo under throttle but no whissle at idle any help would be great thanks tim
 

·
Fixing Broken Stuff
Joined
·
2,078 Posts
Check to see what codes you have.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Checked codes today and this is what I got. 2262 boost not detected and 2285 icp circuit low. Does this meen the icp and map sensors are bad or could it be something else?
 

·
m-chan68
Joined
·
116 Posts
Try unbolting the downpipe from the turbo. Does the engine now rev to and maintain 3800 RPMs when you hold the accelerator all the way down, with the pipe disconnected? Better yet, does full boost return when you drive it with the pipe disconnected? What are your MAP, BARO and EBP_A readings at key-on/engine-off?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
The scanner I used would not tell that stuff just reads the codes anybody close to gate city va or kingsport tn with a good scanner i would love to get it checked in more detail.
 

·
m-chan68
Joined
·
116 Posts

·
m-chan68
Joined
·
116 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #10
I took the down pipe loose and no change and checked it blockages and nothing there. This thing runs awesome with the warmup valve on but when it goes off the power is gone.
 

·
m-chan68
Joined
·
116 Posts
I took the down pipe loose and no change and checked it blockages and nothing there. This thing runs awesome with the warmup valve on but when it goes off the power is gone.
Okay, what exactly do you mean by a "warmup valve"? Did you monitor your EBP_A, MAP and BARO PIDs? If so, what readings were you getting? Better yet, is this an EARLY BUILD 2004 or LATE BUILD 2004 we are working on? Are there any aftermarket gadgets bolted up to this thing?
 
1 - 11 of 11 Posts
Top