Ford Power Stroke Nation banner

1 - 11 of 11 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I have a strange issue with my 04 6.0 torqshift, that hopefully someone can help me. After trans is up at temp and been rolling down hiway for an hour or so and you then stop and take off again the trans will hang in 2nd gear till 3000rpm or so and then slam into 3rd so hard the dash rattles and you break your neck and that it is at medium and sometimes light throttle. Any info would be greatly appreciated. acting this way for last 2 months or so and its not every time but pretty dang close. thank you
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
just had flush and filter change in december. It did the same stuff just before that and then it was fine till january, but I see what you mean maybe some junk came loose I will check it thanks again.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
well checked pan and looks clean no "glitter" . but trans will also be in od and then out of the blue drop down into passing gear and stay there for a few seconds and then it returns to normal. I rebuilt trans 3yrs ago with all suncoast parts and a stallion tc, In december tc hub let go pulled all teeth off, but really didn't hurt input shaft. needed truck so had ford put in new input shaft and stock tc flush fluid and change filters and now its doing this. what do you guys think? I'm sure ford wont help unless its tc going bad but I don't think it could be that I don't though.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
I quit using juice after I lost tc. in december. So since then I have been stock only. Could the fact of having the trans rebuilt with more clutches and the transgo spring (to prevent case lug blow out) be my issue since I dont have a chip. Maybe not enough line pressure?
 

·
Captain Negativity!
Joined
·
3,109 Posts
Sounds like you have plenty of pressure. The pump spring is there as a pop off since the pump can and WILL put out over 300psi if something hangs EPC wide open.

When they installed the suncoast kit do you know if they upgraded the panetary set to the 05 level components?
 

·
<----Nice headlights!!!
Joined
·
1,868 Posts
Bad solenoid in the torqshift? Wouldnt be the first time one of those went bad.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
Yes we upgraded the planetarys to the 05 I beleive. It all came with the master rebuild kit. they also sent a new solenoind in a ford package that I threw in as per instructions. Maybe when they flushed it, it is sticking solenoids but what ones do I replace?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #10
update, tow haul light finally flashed! bad Injector. Not what I was hoping for, I was hoping it was a trans code but nope. Replaced #6 inj and had dealership take it for a spin and they said trans shiffted just fine, wife picked it up everything better. I get back from working in missouri excited to drive truck and sure as s#*! trans acts up again. I am at my witts end hangs from 2nd to 3rd and shifts fine if I let off, shifts really hard if I stay on the gas. solenoid? if so which one(s) would you guys start with? Or can a dealer test them in the truck?:confused:
 

·
Registered
Joined
·
12 Posts
Discussion Starter #11
trannys cooked! 2nd gear solenoid code and a friction code. clutch pack is going or is already gone. OUT SHE COMES! Finally an answer. with trans in limp mode it sure shifts nice thoughLOLLOL
 
1 - 11 of 11 Posts
Top