Ford Power Stroke Nation banner

1 - 10 of 10 Posts

·
Hardcore Redneck
Joined
·
221 Posts
Discussion Starter #1
installed my new exhaust last night, and I must say there were some trying moments. its an MBRP and I liked to have never got the downpipe and intermediate pipe to line up. it rubs the cross member like crazy. anyone else run into this? maybe its because my trucks a regular cab, I dunno seems like I run into lots of snags because of this.
 

·
Hardcore Redneck
Joined
·
221 Posts
Discussion Starter #3
all the pieces came in the kit. I got it to fit w/ a little hammering, just curious if anyone else ever ran across this. I already had a 3" DP so I figured this new one would be really easy. Wrong!
 

·
Demon Dually
Joined
·
5,140 Posts
Did you replace your current downpipe with the one from the kit or did you fit the system to your current downpipe? You should not have to hammer on the exhaust at all to get it to fit.
 

·
Registered
Joined
·
74 Posts
I put the same system on today I used their DP everything slid right together no hammering needed just some wiggling of the intermediate to get it to slide up far enough.
 

·
Hardcore Redneck
Joined
·
221 Posts
Discussion Starter #7
yeah the dp was the one included in the kit. i didnt try to reuse my old one. when i fitted it all together the intermediate was rubbing the trans crossmember where it connects to the upper lip of the frame and i had a gap betweeen the dp and the turbo. it wasnt a uniform gap either. i just couldnt get it to roll around and line up like i wanted it to. i didnt hammer it much, just enough to keep it from rubbing.
 

·
Don't EFN worry about it
Joined
·
15,588 Posts
yeah the dp was the one included in the kit. i didnt try to reuse my old one. when i fitted it all together the intermediate was rubbing the trans crossmember where it connects to the upper lip of the frame and i had a gap betweeen the dp and the turbo. it wasnt a uniform gap either. i just couldnt get it to roll around and line up like i wanted it to. i didnt hammer it much, just enough to keep it from rubbing.
Did you put it all together loosely then adjust, then tighten it all up starting at the DP ?
 

·
Hardcore Redneck
Joined
·
221 Posts
Discussion Starter #9
yep sure did. i just had the trans out so while i was there i clearanced the firewall really well too. its proabaly operator error.
 

·
Registered
Joined
·
95 Posts
I installed it I had to remove the crossmember braket that went to the top of the frame garbage can for that piece
 
1 - 10 of 10 Posts
Top