Ford Power Stroke Nation banner

1 - 20 of 33 Posts

·
Wheres the Spark Plugs?
Joined
·
108 Posts
Discussion Starter #1
I installed a Garrett 38R this afternoon on my Ex. The rear exhaust clamp has owned me all afternoon and evening long. I finally get everything together and go for a drive. Im not seeing anything above 8 pounds with fairly moderate pedal and the truck just sounds different. Has what seems like an injector cackle. We did install a crossover tube for oil at the same time but I dont see why that would change the sound. I look at the rear clamp (from the up pipes) when I return home and it has a black exhaust around it. How do I get this thing to seal back up??? Am I just doing something wrong?
 

·
<--before leveler & block
Joined
·
852 Posts
The cackle you hear is probably the exhaust leak. also there is a dowell pine that aligns the collector and turbo. This may not be aligned right and the turbo and collector may not be fully sealed together. When the clamp is tight, it should be nearly bottomed out so to speak.

Not sure what else i can tell ya. Someone else will chime in soon im sure
 

·
<< wasted fuel >>
Joined
·
1,566 Posts
The cackle you hear is probably the exhaust leak. also there is a dowell pin that aligns the collector and turbo. This may not be aligned right and the turbo and collector may not be fully sealed together. When the clamp is tight, it should be nearly bottomed out so to speak.


:whs: :D
 

·
FORD..THE ROCK CRUSHER
Joined
·
2,342 Posts
The cackle you hear is probably the exhaust leak. also there is a dowell pine that aligns the collector and turbo. This may not be aligned right and the turbo and collector may not be fully sealed together. When the clamp is tight, it should be nearly bottomed out so to speak.

Not sure what else i can tell ya. Someone else will chime in soon im sure
pic of the pin
 

Attachments

·
Registered
Joined
·
531 Posts
Seat the collector to turbo and clamp it before tightening down pedistal bolts.
 

·
Wheres the Spark Plugs?
Joined
·
108 Posts
Discussion Starter #8
So I finally got it to seat right. Took it all the way off and the pin was indeed not slotted into the seat on the turbo. My next question now would be it set of code of P1211 (Injector control head pressure higher or lower than desired). That's a new one for me that it has never set before. Where would you begin running this one down or should I be concerned at all. It did set the SES light off as well.
 

·
Wheres the Spark Plugs?
Joined
·
108 Posts
Discussion Starter #9
Your turbo is toast......I will trade you for a good stocker
I reread your post, I initially read it wrong and thought you were being a sh!thead but see you were making a joke the second time. Sorry for the crappy comment before. :doh:
 

·
<--before leveler & block
Joined
·
852 Posts
Not sure why you would get that code all of a sudden unless maybe you did something to the icp sensor during the install at some point.

Got to love the turbo though!
 

·
Wheres the Spark Plugs?
Joined
·
108 Posts
Discussion Starter #11
Im not seeing anything over 20 - 22 psi with it either. Any clues?
 

·
Going Crazy
Joined
·
1,533 Posts
My guess would be there are still a few small exh or boost leaks that are causing it to be a little low on the psi.. what numbers did it run before?
 

·
<--before leveler & block
Joined
·
852 Posts
Pressure will be a little lower with that turbo than a stock turbo. Also i dont think you will see much more than that with your edge chip.
 

·
Wheres the Spark Plugs?
Joined
·
108 Posts
Discussion Starter #14
My guess would be there are still a few small exh or boost leaks that are causing it to be a little low on the psi.. what numbers did it run before?
Stock Turbo showed 28 psi on the gauge. So I should expect lower pressures now?
 

·
Registered
Joined
·
686 Posts
I reread your post, I initially read it wrong and thought you were being a sh!thead but see you were making a joke the second time. Sorry for the crappy comment before. :doh:
It's ok gets frustrating when $hit don't go right.
 

·
<--before leveler & block
Joined
·
852 Posts
Is that code still coming up? Does the truck seem to run right?
 

·
Wheres the Spark Plugs?
Joined
·
108 Posts
Discussion Starter #19
Yes, you should.
Im so thoroughly confused now. Is this because I havent changed injectors yet? I plan to have Bill @ PHP load a set of custom tunes into the CTS for me as soon as he can (he is a hard guy to reach, must be BUSY!!!). I am assuming I dont have the fuel to feed this turbo now so that is why I am seeing lower boost levels?
 
1 - 20 of 33 Posts
Top