Ford Power Stroke Nation banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello,

I just purchased a 2013 F-250 6.7 with 63K miles. The truck is having an issue where the interior power flickers on and off. ( the dash board and stereo go blank but the engine keeps running). I am let to believe it is over charging based on when I plugged in the scanner. Any Idea to what could be the fix? its going to the dealer next week I just want to make sure it gets fixed correctly the first time. ANy help would be great.
 

·
Registered
Joined
·
102 Posts
I would tend to think it is a connector that is loose and occasionally causes the problem. I would try to find a wiring diagram for the dash that might have a common connector. I would also check the grey connector above the park brake it is known to give problems.
 

·
Master BS'er
Joined
·
5,931 Posts
The first thing ya gotta do is see if it is over charging or not. Stick a voltmeter on the battery when it acts up and see if the system voltage is really that high. If it is, then there is either a short to the field windings, or the pcm is screwed up. The voltage regulators are usually inside the pcm nowadays.

If it's not that high then the dash is screwed up. Pretty sure it's not the dash though cuz the voltge measurement isn't taken at the dash anymore. The pcm reads it directly and sends it over the network. So that information had to come from the pcm.
 

·
Registered
Joined
·
15 Posts
Hello,

I just purchased a 2013 F-250 6.7 with 63K miles. The truck is having an issue where the interior power flickers on and off. ( the dash board and stereo go blank but the engine keeps running). I am let to believe it is over charging based on when I plugged in the scanner. Any Idea to what could be the fix? its going to the dealer next week I just want to make sure it gets fixed correctly the first time. ANy help would be great.
What voltage does the scanner read?? That would help. Do you have a good digital volt meter? Check the battery cables and make sure the connections are clean and shiny. I am guessing dual batteries so be careful taking a cable off, it will still have power from the other battery. It is better to remove both negative terminals first. Then reinstall the positive ones first.

If you test at the battery terminals, you should get about 13.5 to 14.5 volts, with the engine running.
 

·
Registered
Joined
·
15 Posts
Ok, I see I can't edit posts. I do see in your picture the 17.3 voltage. That is quite high. Start with cleaning the terminals and checking the voltage at the battery. I have seen weak connections that would start a vehicle, but not give a good enough connection to charge it properly.
 

·
Registered
Joined
·
1 Posts
Hello,

I just purchased a 2013 F-250 6.7 with 63K miles. The truck is having an issue where the interior power flickers on and off. ( the dash board and stereo go blank but the engine keeps running). I am let to believe it is over charging based on when I plugged in the scanner. Any Idea to what could be the fix? its going to the dealer next week I just want to make sure it gets fixed correctly the first time. ANy help would be great.
I know this is an old post, but what resolved your issue?
 
1 - 7 of 7 Posts
Top