Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I am new to this forum so pardon my ignorance……..I have a 2006 6.0L with a new turbo installed recently and now the VGT Control Valve is making a really loud buzzing noise when the key is on and engine is off. I tried replacing the control valve and it still makes the noise, I also tried cleaning the EGR valve. A little background on this, it is an International chassis with a Gulf Stream motorhome it has less then 15k miles and yes the Turbo took a dump and was replaced with a re built one in December. It seemed to run fine for about 800 miles and recently started to make this annoying noise. The engine seems like it has all the power and does not have any other boost issues. I don't know how to read any codes or have any scan tools and there is no dash lights coming on. Anyone have any ideas?
 

·
Registered
Joined
·
1,069 Posts
Get the ecu reprogrammed it may be corrupt
 

·
Banned
Joined
·
2,444 Posts
Try and find someone who is able to read codes. Im not sure, but doesn't that fall into a class 4 or 5 vehicle?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
By the way it is a VT365 not a 6.0 (don't know if there are any major differences) I have been messing with this thing and slightly bent and tighten the bracket down and the noise subsides…..however you can feel it and tell it is still cycling. Is this normal for it to cycle with just the key turned on? Maybe the bracket was too loose??????
PLEASE HELP
 
1 - 5 of 5 Posts
Top