Ford Power Stroke Nation banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 05 f350, work that has been completed is as follows, 58V ficm w/ 40 hp tune, EGR delete, K&S downloader set on 30 hp tune, head studs, exhaust.

Took the family out to the lake at christmas and let my 10 yrs old daughter drive on the ice, whipped a few dounuts and had a blast, when we went to go home, my tow haul light started to flash and i had no 4th or 5th gears. Took it to a local tranny shop. he checked codes and came up with P2700 and P0725. Told me it was a clutch and shift cel a. I have been doing a little digging and can't find any info for P0725.

I am thinking maybe he wrote down the code wrong? Thoughts? I haven't opened the tranny yet to see if there is any debris....

thanks in advance
 

·
Former Ford Trans Engr.
Joined
·
3,084 Posts
My list shows P0725 Engine Speed Input Circuit Malfunction.

Sometimes driving on ice can set false codes. I recommend clearing the codes and see if they come back. If they do come back we can troubleshoot the problem.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the quick reply and my apologies for getting back to you so late. That lovely thing called work got in the way. So, when I took it to the tranny shop, they cleared the codes, and took it out for another spin. Codes returned. I took it to work a few times and the t/h light started flashing and still no 4th or 5th. I am kinda wondering if he made a mistake when he wrote down the codes.... because he did say I had a "shift solenoid a" code when he looked up the codes.

I know ultimately we won't really know until I open up the pan and see whats inside. Considering doing the solenoid myself, how nasty of a job is that? I do have somewhere I can do it indoors in the warmth as its a touch nasty in Edmonton AB lately.
 
1 - 3 of 3 Posts
Top