Ford Power Stroke Nation banner

1 - 16 of 16 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Ok, I have a 2005 6.0 with right at 139k on it.Within the last 2 months I have replaced the egr plug and put a full delete with up-pipe, oil cooler, and unfortunately a radiator last week because the bottom half of it was pouring out the seams.So now fast forward to today.Im still loosing water/coolant but cannot tell from where.Its not coming from the degas bottle unless I overfill it passed the min level.I also replaced the degas cap with a motorcraft cap less than a month ago.There is no signs of leaking except the level drop in the degas bottle.For example today I drove with no load 2 hrs straight running 182-195 ect and 185-195 oil temp and almost emptied the bottle.I have had my usual diesel mechanic look at it and he seems to think now its the water pump, but hes the same one that told me to replace my egr plug and it would fix my loss.Any help would be greatly appreciated.
 

·
Registered
Joined
·
1,069 Posts
Look under the degas bottle they are leak prone where the hoses connect check for cracks there first, then get under the truck with a flash light look where the upper radiator hose connect to the thermostat housing. Also check the water pump while your under there they have a seep hole on the bottom. The leaks on these truck seem to happen overnight not while the engine is hot so you might check first thing in the morning. As soon as the engine gets hot the trail will disappear
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Thanks for the reply!I have checked the y fitting under the degas and there are no signs of any moisture.I will check water pump and thermostat in the morning.I knew what I was getting into when owning the 6.0 but after 2k in repairs in 1 week. Im ready to get it fixed for good.

Anymore suggestion please keep them coming.I need all the help I can get.

Thanks
 

·
Registered
Joined
·
1,069 Posts
Are you getting a puddle under the truck overnight, guess I should have asked this first
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
No, no puddle on the ground or wetness visual from the top side.All hoses are fine also.We did have to replace the transmission lines at the bottom of the radiator but it had nothing to due with coolant loss
 

·
Registered
Joined
·
1,069 Posts
Any water in the oil, or white smoke
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
No mixing in oil or water system.Im burning oil but not enough to be concerned.Occasional white smoke on real cold morning but only on cold starts.I run rev-x through it every other tank sometimes every tank as I burn through 100-150 gallons a week.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Also running custom sct tunes but I have only had it on economy since I ve had it because of the slow water loss
 

·
Registered
Joined
·
1,069 Posts
Pressure test the system 25 to 30 psi look for head gasket leaks visually the head of the motor may be burning the water off if it's leaking to the outside of the head.... Also start the truck and pull the oil cap off see if it's stemming
 

·
Fixing Broken Stuff
Joined
·
2,078 Posts
Take a look at the EGR delete "J" tube, the hose connection to the oil cooler, those can leak also. You may need to pressurize the cooling system.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #12
Ok little update.Pressurized the system and it held fine.However when I popped the hood I could here coolant flowing or air leaking so Im pretty certain its me degas bottle.Im guessing its cracked on the back side and lossing coolant and its hitting the engine and evaporating.Im assuming this is why there is no wetness or puddles.Gonna go to the ford dealership and grab a new tank and cap and try this again.
 

·
Registered
Joined
·
1,069 Posts
If it's the frags bootleg it would not have held pressure??? It's gotta be your cap that's the only thing that wasn't on the truck when you pressure tested it
 

·
Registered
Joined
·
1,069 Posts
Degas bottle damn auto correct
 

·
Registered
Joined
·
9 Posts
Discussion Starter #15
Yea that didnt click at first but after I thought about I figured that be it.Anyways Im gonna run by ford in the morning and a cap and degas bottle.They have them in stock for a total of $60ish plus tax thanks to my commercial account.I will update again after I get everything put in and put some miles on it tomorrow.

Thanks
 

·
Registered
Joined
·
9 Posts
Discussion Starter #16
Still leaked after I changed the bottle and cap.It was only noticable now in the morning when the engine was cold.I tightened the j hose by the delete and it seems to have stopped leaking while cold.Ill put it to test this weekend and will update.
 
1 - 16 of 16 Posts
Top