Ford Power Stroke Nation banner

1 - 17 of 17 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
It was started on a cold morning and had no power so I thought the fuel was gelling so I put fuel conditioner in but it didn't help. Doesn't want to pull a hill at all...changed fuel filter and didn't help either. Just seems to not be getting any fuel....when idling it acts like it chokes itself out. Any suggestions will be appreciated....thanks!
 

·
Banned
Joined
·
2,444 Posts
Does it only do it while the engine is cold?
Unplug the ICP sensor while idling and see if it clears up.

sent from my Smart Car
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
No I don't have a scan gauge and I checked the voltage on the ficm, which it was replaced last year and I unplugged the icp sensor and it didn't run any better... it acts like its not getting enough fuel and it sounds like i'm letting out on the clutch and the engines under a load...I replaced the oil cooler and done the egr delete 2 years ago... I can't get it to hardly pull out unless its in 4 low, so I cant get it to the dealer unless I haul it and if I let it choke out and die its hard to start back...........this trucks been a nightmare for the past two winters!
 

·
Registered
Joined
·
4,955 Posts
I guarantee you have a P0069 stored in the computer for a map/baro correlation code. Mine does the same thing, no power, i have 0 boost when it happens. It only does it around 0*F. I believe it is a software issue as i watched on datastream MAP, BARO and EBP and nothing was reading incorrectly.

edit: nevermind i didnt see you said it happens all the time. This is only when its cold.

Does the truck build any boost?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Yes it actually builds boost..........the thing is the truck doesn't even hardly smoke at all when I start it and rev it up. A two hour drive to work took me 3 and a half.....wouldn't hardly pull a hill and I would have to go to low gear and I had to pull over on a few of them..........also it got terrible fuel mileage.
 

·
Registered
Joined
·
4,955 Posts
Are there any codes stored? The truck shouldnt smoke unless there is something wrong. Does it run rough at all? What was the FICM volts, KOEO, cranking, and KOER? Also, check your map sensor hose and fitting for being plugged with carbon.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
Its not showing any codes.... it used to smoke when I started it on a cold morning and now it barely does... it runs real rough when I rev it up and when it goes back to idle it runs rough. the volts on the FICM was 48.8....while cranking and to tell you the truth I didn't check it with the engine running. I'll check the map sensor hose and fitting... thanks for your help.
 

·
Registered
Joined
·
4,955 Posts
Check the FICM voltage KOER and cranking also. Sounds like you have some bad injectors at least (or worst case engine mechanical issues) if it is running that bad. What are you using for a scanner? Miles on the engine? Do you have all the updates done (stand pipes, dummy plugs, blue spring, and STC fitting)? Whats ICP/IPR duty cycle? Have you checked fuel pressure? Last fuel filter(s) service and oil change? Do you use OEM oil filters and fuel filters?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
Okay.. i'll have to check the FICM again. I replaced 1 injector last year, had a miss in it. I borrowed the scanner, don't know what kind it was......not an expensive one. It has 180,000 miles. What are all the updates supposed to be on it? I don't know the ICP/IPR cycle.......tell you the truth, don't know how to check it!
 

·
Registered
Joined
·
4,955 Posts
you need a scan tool capable of diagnosing this engine. Very hard without one.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #13
Okay...i'll have to check the FICM again. I replaced 1 injector last year.....had a bad miss in it. I borrowed the scanner, don't really know what kind it was... not an expensive one. It has 180,000 miles on it....the only thing ive done to it is an EGR delete. Don't really know how to check the ICP/IPR cycle. Haven't checked the fuel pressure.........but the secondary fuel filter doesn't seem like its always full of fuel.. just changed the oil maybe a 1000 miles ago and just changed the fuel filters.......filters all stock. noticed that the motorcraft filter i put back on it had a foam wrap around it whereas the other one didn't.........fuel filters where pretty nasty.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #14
okay.........i'll try to get one. Also should it show turbo boost in Neutral while revving the engine? I don't think it ever has before.
 

·
Registered
Joined
·
4,955 Posts
Not really no. Things that should be checked are fuel pressure, codes with a quality scanner (many scanners won't read these trucks), icp/ipr duty cycle, map/baro/ebp pressure, power balance test. The updates are all on the engine. I listed them in a previous post.
 

·
Registered
Joined
·
43 Posts
like other have said get a good scanner. if you are going to be working on the truck yourself, a good scanner is well worth it. i would guess an injector. i had similar problems and used auto enginuity with the ford bundle. showed icp was fine and miss from injector one. the edge juice i use for gauges and the sct did not pick up the code.
 
1 - 17 of 17 Posts
Top