Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello,
Looking for some help. I have a 2005 (built in 10-2004) I a have owned since 2007 been serviced regularly Has 148K miles. The oil psi gauge drops to 0 at idle and it takes at least 30 seconds of cranking before it starts. After it starts is runs good. I replace the oil gauge sending unit which made no difference. Put a mechanical gauge on it which reads 7lbs at idle and 32 at cruise speed. Oil was changed 1000K ago. Has motorcraft filter and stock housing. Checked plunger at base of oil filter housing - works fine. Oil filter housing fills up withing 4 seconds while cranking and holds full with check valve pushed down with 3/8 extension. I conclude it oil pump is pumping good volume. Checked the regulator behind harmonic balancer and the spring and plunger both look normal. Put magnet up inside and found no metal debris. I found a number of threads that indicate similar symptoms with 03 and 04 HPOP where the low pressure check valve ball comes out causing a low engine oil PSI and hard start. According to ford and my VIN my vehicle has the new style pump. Any Ideas?
Thanks,
Brian
 

·
Registered
Joined
·
7 Posts
Look below at my thread and you’ll see mine does the EXACT same thing.

Did you check you filter after it started doing it? Mine has brass and metal shavings even after 2 oil changes which could mean a spun bearing. You’re at least getting SOME oil pressure, mine drops to zero at idle.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hi, Update: Turns out the HPOP is the older style even though the Ford parts department ran the VIN which showed it had the new style HPOP. I had a friend who works for come look at the truck yesterday afternoon and he could tell by looking at the HPOP cover that it was the older 03-04 style. We pulled out the pump and sure enough the ball was missing creating a round hole in the side of the low pressure side of the HPOP causing low engine oil PSI. Drove back to ford to get a new pump which they told me on the phone they had is stock but of course when I arrived they could not find it so I ordered one.
Thanks,
Brian
 

·
"resident smarty pants"
Joined
·
4,162 Posts
Is it an Excursion?
 
1 - 4 of 4 Posts
Top