Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
So about a week ago, I couldn't get air to come out of the front vents or foot vents. Only defrost. Looked up this issue, I saw lots of vacuum pump, 4x4 actuator solenoid or whatever it's called, a vacuum leak, cracked vacuum reservoir, and the blend door actuator. I first checked for leaks, I had none. Reservoir was not cracked. I bought a new pump, 4x4 actuator, and blend door actuator. No luck at all. Replaced all fuses that had to do with all this and still nothing. Checked the connections on the switches, and they were fine. Don't know where to go from here, I'd like to get this fixed soon because it's startin to heat up here in Texas... Thanks
 

·
PSN intsigator
Joined
·
6,608 Posts
There is a black plastic chamber directly behind your passenger battery that likes to get holes in them from rubbing or battery acid eating them. That piece is slightly smaller than the battery

Sent from my super awesome outdated Samsung phone while waiting for masakimms# 500mA overdraw draw to catch fire which turd will be blamed for and we will be sitting on dustybumpers tailgate watching the fire and plotting against yommy.
 

·
PSN intsigator
Joined
·
6,608 Posts
does the vacuum pump run ?
Great question, I assumed it was

Sent from my super awesome outdated Samsung phone while waiting for masakimms# 500mA overdraw draw to catch fire which turd will be blamed for and we will be sitting on dustybumpers tailgate watching the fire and plotting against yommy.
 
1 - 4 of 4 Posts
Top