Ford Power Stroke Nation banner

1 - 20 of 38 Posts

·
Busy Busy
Joined
·
9,004 Posts
Discussion Starter #1
Wondering if anybody can help me here.

Issues:

1) Radio will quit playing, time is still illuminated.
2) Windows will cease to respond to switch, whether they are up or down.
3) Dome light will work off of light switch panel, but not off of dome light buttons.

The problem is intermittent and sporadic. Usually the issue begins with or ends with a relay sounding click. This rules out a fuse, which all are still intact.

It's not the "GEM" module like on the 99-01 trucks.

I think it's the VSM but the door locks work perfectly fine as well as the key fob.

I have read where it might also be a non-serviceable relay in the instrument cluster.

Anyway I can determine the problem instead of just throwing parts at it? I know that Ford will have to program the VSM.

Thanks in advance.
 

·
Busy Busy
Joined
·
9,004 Posts
Discussion Starter #2
Bump? Anyone?
 

·
Village Idiot
Joined
·
8,209 Posts
Long shot but when i had my windshield replaced, my trucked leaked right on back of the fuse block...all kinds of havok...low batteies did some crazy stuff as well.
 

·
Busy Busy
Joined
·
9,004 Posts
Discussion Starter #4
That's because it was hitting the gem. This is an 03 truck, gem is not on the back of the fuse box.
 

·
Registered
Joined
·
574 Posts
02-03 have a issue with the acc delay relay
I have issues with mine still to this day.
 

·
Busy Busy
Joined
·
9,004 Posts
Discussion Starter #6
Yeah, and that's located in the cluster right?
 

·
Registered
Joined
·
1,690 Posts
When having issues like you saying its always been the VSM for me. If you get one from Ford they have to be programmed. However, if you get one with the same cab config, and power options they will interchange truck to truck.


If you have another 02-03 truck you could try it they all do interchange just dont run the options the same. Ex- I installed a SC VSM in a CC truck. Everything worked perfect except the rear doors didnt bring on the dome light. Because the SC trucks dont have the switches in the rear doors.

Also, recently found that apparently 02-03 450s and 550s dont have VSM. If you need some more info PM and Ill give you my shop phone #. Maybe it will help some.
 

·
Busy Busy
Joined
·
9,004 Posts
Discussion Starter #8
I have a crew cab 03 with power Windows, locks, mirrors, etc I could snag one from.
 

·
Registered
Joined
·
1,690 Posts
Id try it. I am betting that is your problem. The dome light is always a key way I have found to what is wrong. I have not seen the instrument cluster stop the dome light from working.

Im not saying its not possible just saying its always been the VSM for me.
 

·
Busy Busy
Joined
·
9,004 Posts
Discussion Starter #10
Replaced the Vsm with one from the exact same cab model. No dice. Works then doesn't just like before. Guess I need the instrument cluster for the acc delay.
 

·
Registered
Joined
·
1 Posts
I'm having the same issue. The door latches were giving me trouble, I drowned them in WD40, solved that issue. The radio only works when it wants too, when it doesn't, I don't even get the display (clock). If I leave the door open till the lights go out, the radio will work for a bit. The radio also comes on sporadically when I'm driving (usually scares the crap outa me). Sometimes, the only way to get the dome light to quit is to remove the bulb, other times, you can't get it to come on to save your life.

This truck was involved in an accident that required a door replacement (driver) this problem has existed ever since they did the repair. I take it to them, they mess with it, say it's working, I get it back, starts all over again.

What is a VSM?
 

·
Registered
Joined
·
13 Posts
Exact same issues here, but add to the mix that the A/C cuts in and out as well. I was told that I needed a new clutch on the A/C, but the instrument panel may be the key to all my problems???
 

·
Registered
Joined
·
264 Posts
I have seen bad connections at Fuse Panel under dash cause these problems, had one that threw me for a while till I started wiggling fuses. This is usually on the trucks with the gem on the back of the fuse panel however.
 

·
Registered
Joined
·
748 Posts
So my 01 where none of the power locks actuate could be a gem modual? You hear them
Just seems
Like not enough power to actually lock and unlock??
 

·
Intelligent Burro
Joined
·
450 Posts
COLETRAIN45, your lock actuators are weak. need to replace them. Its not the GEM.
 

·
Registered
Joined
·
3,940 Posts
So my 01 where none of the power locks actuate could be a gem modual? You hear them
Just seems
Like not enough power to actually lock and unlock??
If the gem was bad they wouldn't make a sound. Actuators are bad. Mine are the same way just haven't taken the time to do the foil mod.
 

·
Intelligent Burro
Joined
·
450 Posts
If I remember right I paid about $40 each for mine. There is a difference between left and right but the same actuator in my e99 is still being used in 2012.
 
1 - 20 of 38 Posts
Top