Ford Power Stroke Nation banner

1 - 20 of 21 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
2000 7.3 died along road starts but dies. Noticed going down hills it would start to die anit puffed out white smoke alot. Could use a fuel filter change 10,000 but I dont think thats it. If anybody has any ideas I would appreciate it thanks.
 

·
Registered
Joined
·
145 Posts
Is there still fuel in the fuel bowl? Last time mine went down it would start and die until all the fuel was out of the fuel bowl. Turned out to be fuel pump. can you hear the pump when you turn the key? If not get under drivers side and put your hand on the pump while someone turns the key to see if you feel it come on.

Wish I could help more...........
 

·
Fixing Broken Stuff
Joined
·
2,078 Posts
Does it have plenty of fuel? oil level? any codes?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
While along side the road I took the fuel filter out to look at it and the bowl was full of fuel. I didnt hear the fuel pump running and I didnt check the feel. The oil level was ok and didnt look like there was water in it but a few bubbles on the stick though. Also the coolant level was good. I did have a p1212 code ICP voltage not whats expected. I had it towed to the camp ground so I can look at it tommorrow. Does anybody know what the EBPV does? Could this be the culprit? Someone said it might be a injector stuck open?
 

·
Im stroke-less
Joined
·
291 Posts
Cps?
 

·
Fixing Broken Stuff
Joined
·
2,078 Posts
The P1212 code is your problem. You need to scan it and read live data so you can see what your ICP is. I'm guessing its going to be 150 - 175 PSI, you need 500 PSI to start and run.
 

·
Fixing Broken Stuff
Joined
·
2,078 Posts
Also look at your ICP sensor, check the connector too see if it has any oil in it. If it does the ICP sensor is bad and leaking oil in to the connector
 

·
Registered
Joined
·
25 Posts
Discussion Starter #8
where is that sensor located? Someone else said it is on the left cyl. head next to the fuel bowl. Also where is the IPR located?
 

·
Fixing Broken Stuff
Joined
·
2,078 Posts
where is that sensor located? Someone else said it is on the left cyl. head next to the fuel bowl. Also where is the IPR located?
ICP sensor in on the top, front of the drivers side head, and has a 3 wire connector. The IRP is on the back side of the HPOP, drivers side, down low in the valley, and has a 2 wire connector that has a wire clip that locks it in.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #10
Thanks for your replies. I will check this morning. I wish this site had a search for reputable mechanics out your home area so I could call somebody I can trust not to take advantage.
 

·
Registered
Joined
·
145 Posts
say where your stuck. Maybe someone can chime in about local mechanics or come help ya out
 

·
Registered
Joined
·
25 Posts
Discussion Starter #12
I am in Flagstaff, AZ. I have heard of NA (northern AZ) diesel from the tow truck driver. The other thing is that I did check the ICP sensor like the toolmangary suggested and there is oil in the connector. Is this something the dealer should stock?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #13
What happens when there is oil in the ICP? Does it not allow the fuel injectors open properly because of loss of pressure?
 

·
Registered
Joined
·
1,557 Posts
oil in the icp usually means sensor is bad or going bad, should be no oil, yes a dealer should have them in stock, pricey, but in stock.
 

·
Do you smell something?
Joined
·
641 Posts
your ipr wiring is shorted out, wiggle the wires on the back or the hpop and I bet you can get it started.... common problem on high milers.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #17
I checked the wiring and I dont see anything wrong. I unplugged and plugged back in all the connectors I could find on the top of the motor. I had a freind try to start it and nothing. Its like it is getting no fuel. I also checked to see if the fuel pump on the frame rail was working and it does. One thing I noticed while looking is that the glow plug relay was getting pretty hot, I touched it on the pos. terminal with diesel on my hands and it smoked a little. I have never noticed that before, but never looked.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #18
Just thought I would update. I had the truck towed to the Ford dealer they said it was the HPOP going bad and also the IPR. I talked to a Nate at Strictly Diesel and he said from the symptoms I was describing that it could very well be the problem. They are fixing it now and I am supposed to get it back tomorrow. Hpoefully no more issues.
 

·
Registered
Joined
·
1,277 Posts
Order an ICP sensor off of Ebay, WAYYYYYYYYYYYYY cheaper than the dealer. I paid $91 shipped for a factory sealed ford part. ToolmanGary says to search on ebay under 7.3 ICp and then you should find one for around 65 bucks.
 

·
Registered
Joined
·
446 Posts
pull that IPR, take it apart, clean it up real good, get a reseal kit for it and I bet it'd fix your problem
 
1 - 20 of 21 Posts
Top