Ford Power Stroke Nation banner

1 - 20 of 29 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I have a 1999 F350 Powerstroke. It has 282,000 miles on it. I just bought the truck a couple days a for $3500. It is a flat bed truck. Body is in perfect condition. Was that price too much? I drove the truck home which was about 50 miles and it ran like a new one. I drove it around locally and it ran fine until today. The engine sounds perfect no rattles or anything out of the ordinary. I drove about 8 miles and I sorta felt a hesitation when I would mash the throttle all the way down. It quickly got worse quickly. It got down so bad that I had to go to low gear (the truck is a 6 speed 4x4) low fourwheel drive to get it back home. It smoked really bad and sounded like it was only running off of one cylinder. The smoke was a white blueish smoke. It so weak a riding lawn mower could have passed me on the road. It would jerk try to run but just wouldn't. When I would pull off the road the truck would still idle but not normal I would have to give it any fuel for the truck to idle. Well I came home, change fuel filter, cam sensor and that didn't help it. Well after the truck cooled completely off I started it, and it sounded like a new one idled just fine. I drove it down the road and it seemed to be fine. When I would come to a dead stop and take off from low opening the throttle full I would get a hesitation with a buff of white blue smoke and it would take off. It wouldn't do this if I didnt open the throttle wide open. Air filter is clean and the turbo seems to be working fine. I am new to these trucks and need some ideas and some help and no one around here knows a whole lot about them. Could it be the high volume oil pump? injectors? some that is breaking down when it gets hot? Some one please help I will try anything. Thanks ( I forgot there is no check engine light or anything that comes on)
 

·
Super Hauler!
Joined
·
3,882 Posts
UVCH pull your valve cover off and it will be melted. Replace and go on you way. A good way to check is open your hood, it will smell like burnt plastic. No big deal happens a lot.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Thanks for the reply, I dont mean to sound dumb what is a UVCH? I dont remember smelling and thing burnt that I can remember.
 

·
Registered
Joined
·
2,897 Posts
That means under valve cover harness, it is the injector and glow plug wiring that is built into the cover gasket. When they drop you usually lose four cylinders (check the exhaust manifolds...they should both be hot).

In my experience they are not intermittent, they go and thats it.

Your problem sounds more like a bad hpop (high pressure oil pump) or ipr (injector pressure regulator). These commonly cause hot run issues, and are intermittent.
 

·
Registered
Joined
·
1,209 Posts
I would start by pulling the valve covers and poking around to see if anything is obvious. The harnesses should be readily available from the dealer. Sounds about right to me since it goes from fine to fail. Might also do a LOF(lube oil and filter) on it since they tend to run like #### when the oil is wore out
 

·
Registered
Joined
·
1,209 Posts
Good call
 

·
All done now
Joined
·
22,486 Posts
With that many miles, I am voting for injector issues. But also check out what everybody else is saying first.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #10
I have checked the wiring under the covers and it seems fine. Here is a issue I am not sure about. When I changed the fuel filter there is red diesel in it. Would that have a big effect on the injectors not working properly? I am sure that the people that I bought it from have run everything in it. Is my injectors messed up? I drove it about 1/2 mile this evening and it was falling flat on its face. Any ideas?
 

·
Registered
Joined
·
1,209 Posts
Lol cheap isn't a word associated with our injectors
 

·
Registered
Joined
·
1,209 Posts
I can't remember for sure but I think you can send them into jim at rosewood and he will replace what needs replaced or can tell ya that they are junk and start new
 

·
Registered
Joined
·
3,940 Posts
Just for kicks drain the fuel bowl. Fill it with seafoam and give it an enima. I do this from time to time. When you start it it will get a good dose of cleaner. And the uvc issue. When mine went bad it was intermittent for 2 weeks and then I had it scanned. Replaced the clips not the harnesss and it's been fine for 2 years now. Those clips will get weak and not hold good enough. Just something else to try before spending money for inj. Have someone scan it with ae and find out for sure before buying the inj. Remans are around $1200 plus labor new ones are like $2800. Good luck.
 

·
Custom Trailer Sales
Joined
·
6,161 Posts
Sounds a little like injectors, and its about the right time like Moore said.
Does the truck fire on all cylinders on a cold start?
 

·
Registered
Joined
·
745 Posts
I dont like throwing parts for fun for what you have in the truck buy new injectors.

The UVC harness and gasket are known to cause this issue cuz they are affected buy heat. Scanning dosent always point to a bad UVC or injector due to the PCM not getting the signal any way. With that kinda milage it wont hurt to reaplace the UVC and the gasket were talking alittle over a hundred bucks. And you will know that is not the problem. You cant pull the valve cover and just look at the harnes and gasket conections you need to do a continuity test of each and every wire. Get new and go from there.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #18
Well I with a some investigation I am pretty sure that the engine is shot or on its way. The breather tube has about a quarter inch of oil an dust build up in it. The truck has so much blow by it looks like a smoke stack. I am sure the engine is no account due to dust and dirt being sucked in to the motor. I am debating on doing a engine rebuild or buying a new engine. I do not know where to find a good crate engine at. I cant find anything from Jasper engines. They want you to locate an installer for the engine. I will put it in myself If I can find a good quality one. Has any one got any ideas where I can order an engine?
 

·
All done now
Joined
·
22,486 Posts

·
Registered
Joined
·
1,209 Posts
Agreed. Jasper products i've had terrible luck with
 
1 - 20 of 29 Posts
Top