Ford Power Stroke Nation banner

1 - 9 of 9 Posts

·
mtnash99
Joined
·
5 Posts
Discussion Starter #1
Hey everyone I have a 97 psd and I've been having a problem with it while driving. The truck idles just fine, and drives fine most of the time. Every once in a while I'll be driving and the rpm just like drops. It's not just the tac cuz I sure feel it especially if I'm building boost. I can't find any like chain of events where it does it. It's just randomly doing it.at first it was every once in awhile, like twice a month, but now I can be as often as a couple times a day and then sometimes it won't do it for a while and then it starts back up
 

·
Super Moderator
Joined
·
8,067 Posts
I would start by changing the cps. Very common for it to go out. Use ford or international parts only.
 

·
CAT lover
Joined
·
593 Posts
I'll second the CPS. Buddies truck did exactly this and I threw a CPS in it bam fixed.
 

·
Registered
Joined
·
3,351 Posts
Yup Classic cam position sensor on the way out. Go to dealership buy two, install one and keep the spare in the glove box. When you install it’s a 10mm bolt, use a six sided socket, sometime bolt can be tight and you don’t want to round the head. Upon install of this bolt do not cross thread as the front engine cover is aluminum that the bolt goes into. You do not want to cross thread this bolt, was down that path one time..... just take your time. If you cross thread this bolt it means pulling the front end off the truck to install a hellicoil and is a Royal PITA.... hahaha. Also I use a quality anti seize paste on the threads.
Cheers,
j
 

·
mtnash99
Joined
·
5 Posts
Discussion Starter #6
Well everyone, I got the sensor and went to take the old one off. Previous owner stripped the bolt. I've tried vise grips box wrenches etc. This thing is being a pos
 
1 - 9 of 9 Posts
Top