Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
1997 7.3 Power Stroke Diesel
The problem that I am having is that the truck shuts off while driving. It has always been between 35 to 50 mph. It has happened while on the gas or while coasting. The dash looks like I just shut the key off except after four or five seconds the check engine light comes on as well as the battery charging symbol.
It will do it once or two or three times in a ten or fifteen period of time then run fine for three or four weeks.
A couple of times it started right up as soon as the truck stopped, but typically it takes about ten or fifteen minutes before it will start back up.
It does it on either fuel tank. I have changed the fuel filter, cleaned out the filter housing and the front fuel tank. None of which helped.
Fuel pressure tested normal: 20 plus while cranking, 50 under no or slight load, no lower than ~28 when under extreme load (towing floored up hill).
I have changed the camshaft position sensor which didn’t help either. It also shows rpm on the tach when it is turning over but not starting.
The codes it shows (I read these after the second and third episode (disconnected bat. to clear between episodes).) were:
P0344 (only came up the first time) Continuous camshaft position sensor A circuit intermittent (bank 1 or single sensor) Update: P0344 came up once by itself and the truck didn’t stall or even sputter.
P0340 (came up both times) continuous camshaft position sensor A circuit (bank 1 or single sensor)
P1211 (came up both times) continuous injector control pressure above/below desired
That’s about it. Any help would be greatly appreciated.
God bless you all, Ed

Also, the vref contact from pin 90 on the PCM to: the MAP, BARO, Accel. Pos. sensor, EBP sensor, ICP sensor, and the CMP sensor ohmed out at ~350 ohms where it should have been greater than 1000 ohms. I disconnected each component and re-measured with each disconnection with very little change in the measurement (~ 350 ohms). It wasn’t until I disconnected the final thing which was the PCM. It then showed as open. About an hour later I measured pin 90 on the PCM with the harness off which then measured open. Then when I re-connected the PCM it measured well over the 1000 ohm normal reading. This continued with each component that I reconnected.
The vref. From pin 90 does measure the normal 5volts during the key on test though.
This seems like it may be related to the problem since the errors are for both the CMP and ICP system which are both fed by this same vref.

I also wiggled, twisted all the wiring harnesses that I thought could be involved with the truck running but it gave no codes and didn’t stall or spudder.

Any help would be greatly appreciated.
Take care and God Bless you all, Ed
 

·
Fixing Broken Stuff
Joined
·
2,078 Posts
Well I think your problem is the P1211 code ICP out of range. From how you describe it it sounds like it is on the electrical side and not the mechanical side of the ICP system. Check the tin nut that holds the coil tight on the IPR valve too see if it is tight. if that doesn't fix it then I would say it could be the coil on the IRP valve, wiring, or the PCM. If you have a tuner or chip remove it and try that first.
 

·
OBS junkie
Joined
·
8,250 Posts
Well I think your problem is the P1211 code ICP out of range. From how you describe it it sounds like it is on the electrical side and not the mechanical side of the ICP system. Check the tin nut that holds the coil tight on the IPR valve too see if it is tight. if that doesn't fix it then I would say it could be the coil on the IRP valve, wiring, or the PCM. If you have a tuner or chip remove it and try that first.
:whs:

Also check the wiring on the IPR. I've seen the wiring rub raw & cause it to cut out while driving.
 

·
Drive it like ya stole it
Joined
·
186 Posts
Might want to check the wiring with to the ICP as well, I had a 1211, went through all the troubleshooting steps and couldn't get rid of it, turned out to be a loose ICP plug...just a thought.
 
1 - 4 of 4 Posts
Top