Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
So a little back story, rebuilt the motor top too bottom about 7 months ago and have been driving the truck intermittently since then. The other day had to move around the driveway and it shut off and would not restart and hasn't since. It will crank till the cows come home but no smoke no sputters or anything. It is getting fuel pressure (70 psi, electric fuel), I have checked every fuse, relay and just about everything else electrical. I have a ts 6 position which I removed from the pcm to see if that was the culprit, still nothing. I put a new motorcraft ipr in during rebuild. Tried unplugging the icp, which I have had issues with in the past, that didn't do anything. Ohmed all injector wires and checked for power during cranking. The injector wires ohmed perfect and they were getting power during crankig. Now today I was messing with it and noticed the hpop res was empty, atleast I couldn't see anything in it. So I filled it up and tried cranking, still nothing, but after cranking I checked it again and it was empty. Could this be a bad hpop? Or the ipr sticking or something letting it drain? I've seen that if lpop is bad/weak this could happen but if you fill the hpop res it should atleast try and start. I also noticed I wasn't getting any rpms while cranking so it probably will help to put a new cps in but I'm more worried about the oil draining back. So I'm completely at a loss where to go now, any advice will help. Thanks, and sorry for the long read just trying to give as much detail as possible.
 

·
Registered
Joined
·
2,861 Posts
Check the main oil level. You may need to check the main lube oil pressure while cranking (there is a port down by the oil filter). Any CEL? Wait-To-Start coming on as normal? If the IPR is not powering up a CEL should set, but I've attached the pinpoint tests for IPR power you can do (don't assume the PCM is bad if the last test fails unless P1283 is being set!!). The tests are just another set of wiring tests. I'd try another CPS too (OEM only!). Cheers!
 

Attachments

·
Registered
Joined
·
30 Posts
Discussion Starter #3
No CEL, wait to start comes as normal, I'll have to check the low pressure see what its reading and throw another cps at it. Thanks for the info!
 

·
Registered
Joined
·
8 Posts
What other work have you done recently? Oil drain back can come from either the HPOP or the oil pressure regulator in the rear end of the oil cooler.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
Since I got the truck running and have been driving it I haven't done any other work to, not even an oil change yet.
 
1 - 5 of 5 Posts
Top