Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have watched all of DieselTechRons (RIP) videos, but Im stuck here. 1st Ill start at beginning, and try not to make a novel, but if your reading and have ideas, thank u so much ahead of time..
Over a year ago I come out to start it for work & crank no start (no signs or previous issues before). I worked 75ish hrs a week at the time so towed it to Mike Naughton Ford here in Denver, had it for 3 weeks, said it was ready and that I had aftermarket oil filter cap. (Ive had the truck for 5 years at the time) But whatever, paid 330$ and was happy to get my baby.
A month later, drove to work fine, but end of shift, crank no start.....cpl weeks later towed it to another shop...(heavy equip mechanics) who I had a good relationship with, and always kept my 60T crane (International) up & runnin.
Im sure he added more issues than he fixed, but got it back on a Thurs, crank no start on Sat.
It sat a few more weeks, towed it to Dgls Cty Diesel, 2 days later picked it up free of charge, when asked him the problem, he said "Idk, we just wiggled some wires around and it started".
After a few more weeks, this time died while driving. Towed home and been working on it myself since. Heres what Ive done so far;
REPLACED PARTS;
-IPR VALVE
-ICP SENSOR & PIGTAIL
-BLUE SPRING KIT
-UPPER/LOWER OIL PAN GASKETS
-BOTH BATTS, YELLOW TOP OPTIMAS
I have a scangage2 & currently reads;
IPR= 84.3 when cranking
ICP= 275ish psi
FSYC= 1
FVLT=48ish
I did the air test thru icp port, didnt hear/see any signs of leaks, put icp sensor back, had lunch & rewatched air test videos and noticed I didnt have oil cap off while pushing in air...when i got home i started cranking to see if gage readings changed, but after about 20 seconds it STARTED. WTF?? I was on cloud 9, lol. Let it idle 20 min, then drove around home, noticed accellerating felt rough, as if my tire treads were super uneven, but theyre new. Anyway after about 15 min of drive time, it died while driving. Just the motor, all lights, etc stay on.
Since then Ive ordered the box that can command IPR to on/off. Have not tried it yet..
Sry for the novel, but any input is very appreciative. Idc what they say but this truck is BAD a$$ (even broke down in my driveway) LOL.
PS. When it started, scangage read;
ICP= 2500ish PSI
IPR=30-40%
THANKS AGAIN,
ROB
 

·
Registered
Joined
·
776 Posts
You have a hpop leak somewhere, what year truck?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
You have a hpop leak somewhere, what year truck?
2006......so I need to do the air test thru the icp, once i put shop air thru am I suppose to have the oil filler cap off??? I did it with it on, didnt hear or see a leak???? Thanks for your time.
 

·
Registered
Joined
·
776 Posts
Idk I haven't done the icp air test, you will just have to search for it, it has been posted a bunch of times.

I would look towards the direction of the updated dummy plugs and I rings and the stc fitting.
 
1 - 6 of 6 Posts
Top