Ford Power Stroke Nation banner
1 - 4 of 4 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
hey guys i have a 2005 6.0 with sct on street tune, it used to blow black smoke when i revved it up or got on it, now all of a sudden when i was driving it today it started missing at high rpms and doesnt blow smoke anymore. no new codes either, currently checking fuel pressure and system. forgot to mention i have the fpr blue spring upgrade and 6.4 banjo bolts thanks a bunch guys..
 

·
Registered
Joined
·
41 Posts
Have you checked your EGR valve? Mine recently did the same. Pulled it out for the first time at 75K and it was sooted up real good. Cleaned it up nice and the truck ran great. Then the valve went bad. I pulled it out, closed and re-installed it. I've left it unplugged since (about 2 weeks). Honestly, the truck never performed better.

I'm thinking of tack welding it shut and plugging it back in so I can reset the CEL.

Good luck.

This is what my EGR valve looked like when I pulled it......

 

·
Registered
Joined
·
59 Posts
Discussion Starter · #4 ·
truck still has me scratching my head put a new fuel pump in it, changed filters, dropped the tank to check strainer still same problem, and the truck has an egr delete kit on it. After leaving the truck sit all night on the sct street tune it smoked and had power kinda acted normal. But know running weird again no smoke, and miss at higher rpms at wide open throttle.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top