Ford Power Stroke Nation banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I installed a new sct ts live wire programmer, took it for a test drive. Soon as I pulled out on to the road I punched it and I guess I got to about 60mph and it died and won't start back. Didn't make any noise or nothin just like I turned the switch off. It'll turn over but won't start. I checked all the fluid levels, I even unplugged the icp sensor still won't start. It threw a p2285 code I think. Even returned the truck back to stock tune with the programmer. It also shows low fuel level but I know it has just under half a tank. The oil pressure gauge won't come up while I try to start it either. Haven't had a chance to check any fuses yet I just had to have some one come with a trailer and get it back home. I tried to crank it while it was cold the next morning and the batteries were dead but it was turning over great the night before and has been. Any ideas would be great. I just put a egr delete on it a week ago also haven't had the truck a month yet.
 

·
Registered
Joined
·
1,459 Posts
sounds like you may have a HPO issue. I would try and get a computer on it and see what your IPR is while cranking. The 05-07s have a fitting on the HPOP call the STC fitting that commonly fails.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Okay ill try to do some more checking on it when I get a chance from work, I just hope the programmer didn't do it, but I bought it brand new not used or anything
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Well it has no codes now, I returned the trick back to stock as far as the programmer goes. If the irp blew the screen would it die and still not start back?
 

·
Fixing Broken Stuff
Joined
·
2,078 Posts
See what you have for ICP while cranking, also look at FICM voltage.
 

·
Registered
Joined
·
1,069 Posts
It really sounds like the stc fitting, mine did the exact same thing. I was hard accelerating truck lost power coasted to a stop no oil pressure.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
using the programmer for a gauge, the icp pressure while cranking is about 60 to 70 psi with cold oil. i know that way to low for it to start. what could the programmer have done to cause it to die? could it have turned the high pressure up some how? im new to the 6.0 but am familiar with heui style engines
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
pulled the turbo today, pulled ipr out it had a cut o-ring and the screen wasn't blowed but it wasn't on the valve it was just loose in where the valve screws in. no missing pieces on the screen just not attached to the valve. got a seal kit and replaced the screen and seals on valve. figured that cut o-ring was it so i put it all back togehter and tried it and it still wouldn't start. i should have pulled the hpop out while i was there to check the stc fitting so i guess tomorrow im gonna tear back into it and check it. it was stupid on my part to not pull that pump and look at that fitting. anything special i need to know on pulling the hpop once i get the turbo and all back out of the way?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
found one little piece of debri in ipr. it was holding it open so it wouldn't build pressure.
 

·
Fixing Broken Stuff
Joined
·
2,078 Posts
anything special i need to know on pulling the hpop

Don't drop the bolts.
 
1 - 11 of 11 Posts
Top